On my new PC something is wrong with ACPI support under Linux. I have to boot it with acpi=off and nolapic. Also it detects only one CPU core (this annoys me the most) and won't shut down completely, I have to hold power button for few seconds to power PC off.

The question is: what can I do? Edit some config files? Report bugs? Send mails to motherboard manufacturer? Run some utility to help reverse-engineer drivers? (Currently I just turn AMD C1E off in BIOS. It's a nice workaround.)

My configuration:

  • Ubuntu 12.04 (upgraded from 11.10)
  • Processor AMD FX(tm)-4100 Quad-Core
  • RAM 8,00 GB
  • Graphic Gigabyte GV-N56GOC-1GI (NVIDIA GeForce GTX 560)
  • Mainboard Gigabyte GA-870A-USB3
  • Why do you have to boot with both acpi=off & nolapic? What happens if you do not use those kernel options? Having only one CPU core is apparently a result of disabling ACPI. See this question: Is SMP running on my computer? Commented Apr 29, 2012 at 19:25
  • @irrational-john Without them system won't boot (this applies both to live and installed systems).
    – user31389
    Commented May 6, 2012 at 12:53
  • Also if I can help fix it (by providing some dumps or command outputs for example), I would do it.
    – user31389
    Commented May 6, 2012 at 12:57
  • Tell me, are you running 12.04.4? I found on my laptop, I had the same issue with you on 12.04.4 or later in Ubuntu and Lubuntu. So I went to old-releases.ubuntu.com/releases/precise and downloaded 12.04.3, and guess what.. worked! Did you want to try that and see if it does the same for you? If so, something has changed in acpi 12.04.3 > 12.04.4 that has stopped it working on some computers.
    – MicWit
    Commented Apr 3, 2014 at 13:31
  • @user264771 I ran every Ubuntu from 11.10 to 13.10 on this PC. 12.04 was a first release, not a point release. I just disabled AMD C1E in BIOS and it all works now.
    – user31389
    Commented Apr 3, 2014 at 18:49

2 Answers 2


I suggest you start by trying to follow the steps in this guide: DebuggingACPI.

The description at the top of that page says it is part of Debugging Central, "pages with debugging details for a variety of Ubuntu packages" on the Ubuntu Community Wiki.

You should also try looking at the entries in /var/log/syslog to see if anything there will help isolate the problem.

Make sure the portion of the log you look at is from a failed boot. That is, the log entries should be from a boot where neither acpi=off nor nolapic were used. The log timestamps should allow you to determine which boot a log file entry is from.

If you find it easier to use a GUI application, Ubuntu has a Log File Viewer which you can use. It can be found by searching for it using Dash. Dash icon from my desktop

The steps below are (pretty much) copied from the DebuggingACPI page and are what I suggest you do to try to isolate the problem before filing a bug report. (I believe the procedures for reporting a bug are also on the DebuggingACPI page)

If acpi=off allows the system to boot, try to isolate the ACPI issue with the following boot parameters. Remove acpi=off and boot with only one of the options below.

If you are lucky, you might find a combination of kernel parameters which allows you to boot and use all the cores of your CPU.

Note: If you need an explanation of to how to do a "one time" change of the kernel boot parameters/options, try this answer to the question "How do I add a kernel boot parameter?".

  • Try booting with acpi=ht
    This disables all of ACPI except just enough to enable Hyper Threading.

    If acpi=off works and acpi=ht fails, then the issue is in the ACPI table parsing code itself, or perhaps the SMP code.
  • Try booting with pci=noacpi
    This disables ACPI for IRQ routing and PCI scanning.
  • Try booting with acpi=noirq
    This disables ACPI for IRQ routing.
  • Try booting with pnpacpi=off
    This disables the ACPI component of the Linux Plug and Play code.
  • Try booting with noapic
    Disables the IO-APIC for IRQ routing or PCI scanning.
  • Try booting with nolapic
    Disables the local APIC.


There is a better workaround than disabling ACPI (by using acpi=off and nolapic). You can just turn AMD C1E off in BIOS!

It still is an issue though...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .