1

I have an Acer ET322QK monitor. It works with Windows 10, Ubuntu 18.04 and Linux4Tegra. However, when connecting my computer with newly installed Ubuntu 20.04, it cannot seem to use the monitor properly. In "joined" mode it is black. If I mirror it, it will show the desktop on one fourth of the monitor but I am not able to control anything with the mouse. When I tried to use it as the only display it put me in some kind of state where I had to restart the computer by pressing the power button to gain control again.

It should be noted that the settings recognizes the display just fine. It lists it as "Acer Technology 32 inch" and the list of resolutions I can choose from looks right.

I see that there are many posts about monitors not working and usually it is resolved by updating a driver or something. However, I am not good with these things. Could someone advise me what I should do in my situation? If it is a driver I need, how do I know which one?

As for the additional drivers in the settings:

Drivers

The default was "Using X.Org X server" and that is the one that seems to work best. The one selected in the image didn't seem to recognize the monitor, as it wouldn't show up the displays menu.

Running dpkg -l *nvidia* in the terminal yields this:

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                             Version                 Architecture Description
+++-================================-=======================-============-===============================================
un  libgldispatch0-nvidia            <none>                  <none>       (no description available)
rc  libnvidia-compute-450:amd64      450.66-0ubuntu0.20.04.1 amd64        NVIDIA libcompute package
un  libnvidia-ml1                    <none>                  <none>       (no description available)
un  nvidia-304                       <none>                  <none>       (no description available)
un  nvidia-340                       <none>                  <none>       (no description available)
un  nvidia-384                       <none>                  <none>       (no description available)
un  nvidia-common                    <none>                  <none>       (no description available)
rc  nvidia-compute-utils-450         450.66-0ubuntu0.20.04.1 amd64        NVIDIA compute utilities
rc  nvidia-dkms-450                  450.66-0ubuntu0.20.04.1 amd64        NVIDIA DKMS package
un  nvidia-dkms-kernel               <none>                  <none>       (no description available)
un  nvidia-kernel-common             <none>                  <none>       (no description available)
rc  nvidia-kernel-common-450         450.66-0ubuntu0.20.04.1 amd64        Shared files used with the kernel module
un  nvidia-kernel-source-450         <none>                  <none>       (no description available)
un  nvidia-legacy-304xx-vdpau-driver <none>                  <none>       (no description available)
un  nvidia-legacy-340xx-vdpau-driver <none>                  <none>       (no description available)
un  nvidia-libopencl1-dev            <none>                  <none>       (no description available)
un  nvidia-opencl-icd                <none>                  <none>       (no description available)
un  nvidia-persistenced              <none>                  <none>       (no description available)
rc  nvidia-prime                     0.8.14                  all          Tools to enable NVIDIA's Prime
rc  nvidia-settings                  440.82-0ubuntu0.20.04.1 amd64        Tool for configuring the NVIDIA graphics driver
un  nvidia-settings-binary           <none>                  <none>       (no description available)
un  nvidia-vdpau-driver              <none>                  <none>       (no description available)

This is the result of sudo lshw -C video:

  *-display                 
       description: VGA compatible controller
       product: NVIDIA Corporation
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:150 memory:c6000000-c6ffffff memory:b0000000-bfffffff memory:c0000000-c1ffffff ioport:5000(size=128) memory:c5000000-c507ffff
  *-display
       description: VGA compatible controller
       product: UHD Graphics
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 05
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:149 memory:c3000000-c3ffffff memory:a0000000-afffffff ioport:6000(size=64) memory:c0000-dffff
  • Try choosing a lower resolution size... like 1080... and see if it works then. Are you connecting via HDMI? – heynnema Oct 3 '20 at 22:23
  • @heynnema Thank you for your response. At first it seemed like it was doing something. Instead of the desktop taking up a fourth of the screen, I was seeing the screen displaying perhaps 3/4 of the background. But then it went back to being dark and I couldn't reproduce this. Yes, HDMI. – C. E. Oct 3 '20 at 22:34
  • What resolution(s) did you try? Try 720. Do you have another HDMI cable? Cheap cables are... cheap. – heynnema Oct 3 '20 at 22:35
  • @heynnema I tried them thoroughly now, starting at the smallest resolutions and working my way up. I could get it to consistently display something now. However, everything including the background was way too large. When I went past some point the background became more reasonably size for the display, but then the other monitor start showing up on the external monitor. I don't have another HDMI cable unfortunately, however this computer has dual boot and it works with this cable with Windows on this machine. – C. E. Oct 3 '20 at 22:49
  • Whether it works in Windows, or not, means nothing about how it might work in Ubuntu. I really think you should get/try another good quality HDMI cable. Steal one from your DVD player or DirecTV box, if you got. – heynnema Oct 3 '20 at 22:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.