7

I have a MacBook Pro and only use Ubuntu on it. I just upgraded from 18.04 to 20.04.

Now when I start the computer it says:

Failed to Set MokListRT: Invalid Parameter
Could not create mokListRT: Invalid Parameter
Importing MOK states has failed: import_mok_state() failed: Invalid Parameter
Continuing boot since secure mode is disabled.

Does anyone know EXACTLY how I can fix this?? Step-by-step process I don't want to mess anything up trying to fix this.

9

You have to replace shimx64.efi with grubx64.efi as follows:

sudo su -
cd /boot/efi/EFI/ubuntu
cp grubx64.efi shimx64.efi
reboot
| improve this answer | |
  • Thank you so much! – ubuntu18help Oct 4 at 19:05
  • Point of reference for others. This does not work for the same error message on a 2010 iMac (coreDuo). The error may be more subtle or the older machine may need an even older version of grub. – Jonathan Gutow Oct 10 at 0:55
  • this works also on MacBook Air 2015 model, You are awesome sir, thank you – GGEv Oct 18 at 16:11
1

Solution that works on my 2010 iMac. Install rEFInd and make sure to boot from the option that specifies grubx64.efi.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.