3

NordVPN on Windows has a feature called 'Invisibility on LAN', which, if disabled, allows the device connected to the VPN to still be discovered by other devices on the local network.

When this feature is enabled, the device is not visibile on the local network, and you can't access things such as your router page.

It seems that, by default, my Ubuntu computer, while connected to VPN, is not discoverable on the local network, and as such, I can't access my router or any local devices. In the settings, I also can't see any option called 'Invisibility on LAN' or with a similar name.

How can I make my computer discoverable on the local network, but still be connected to the VPN while acessing the internet, like I can on Windows?

1
  • This seems to be more of a feature of NordVPN than Windows or Ubuntu. Nord VPN will be able to help more.
    – crip659
    Oct 3 '20 at 0:43
5

Registered here just to answer this question. Long time lurker.

I had the same problem. There is no flag/option for the "invisibility on LAN" feature, however, you can whitelist your entire subnet or a range of it and it effectively fixes the issue.

In my case, I implemented:

nordvpn whitelist add subnet 192.168.1.0/24

This immediately opened up my LAN with NordVPN enabled.

1
  • Thanks! I was whitelisting specific ports, but that affected both my LAN and WAN. This is a much better fix. Oct 4 '20 at 0:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.