0

I have tried to install XUbuntu, Lubuntu or Kubuntu on a MacBook Pro 2007 but failed. Indeed, it cannot boot from bootable USB stick or a live bootable DVD. the machine is: MacBook Pro - processor 2.16Ghz Intel core2 Duo with almost 4GB RAM.

So I have tried to boot from a USB stick and a livd DVD, but:

  • Bootable USB does not show up on Mac EFI boot nor on rEFInd as a bootable device. Details - USB stick is recognized, selecting it drives to this message:

Starting Legacy Loader Using load options USB The firmware refused to boot from the selected volume. Note that external hard drives are not well-supported by Apple's firmware for legacy OS booting.

  • bootable DVD appears on both Mac EFI boot and `rEFInd, but it is not recognized as a bootable device, while the macbook burned the iso on DVD! Details - selecting DVD, I get the following message:

Select CD-ROM Boot Type:

(Note that USB stick works on other computer, DVD too.)

Summary: I cannot boot [LBX]ubuntu from an external device.

Is there an alternative? I was thinking booting in Ubuntu from Mac OSX, or havinf an iso partition on the disk where i could boot from...

A suggestion? Anything I could do before i trash my old MacBook Pro laptop?

Thank you

5
  • Are you sure your "Bootable USB` is an EFI Bootable USB? Which option did you choose? Pick the other, recreate the USB, and try again.
    – waltinator
    Commented Oct 3, 2020 at 0:22
  • The machine is old. I came across this:askubuntu.com/questions/931455/…
    – Jay Gee
    Commented Oct 3, 2020 at 11:42
  • @waltinator the "bootable USB" is an EFI bootable USB. Now i have spotted the problem I think: machie is old, EFI boot is 32 bits adn cant work with current EFI 64 bits boot. Needs to figure out if Rufus can do a 32bits usb boot
    – Jay Gee
    Commented Oct 3, 2020 at 11:44
  • I have made 3 attempts in order: 0 - building a bootia32.efi by myself -> interesting project. Failed / 1 - Build a live Kubuntu 64bits 20.04 bootable USB using bootia32.efi and grubia32.efi from Debian -> Boot process works but cannot find the boot loader, stuck at GRUB command. Failed / 2 - get a live Debian 10.6.0 amd64 i386 bootable USB. Works. I hope my laptop will have enough Ram and CPU to handle Debian.
    – Jay Gee
    Commented Oct 3, 2020 at 17:05
  • I am happy to collect advises on whether building my own bootia32.efi in order to install Ubuntu 64 bits. Note that there is an existing bootia32.efi mentioned here: askubuntu.com/questions/931455/…, but did not work for me
    – Jay Gee
    Commented Oct 3, 2020 at 17:09

1 Answer 1

0

The EFI boot of this MBP is 32 bits. While the machine is 64 bit. a bootable USB with a 64 bit Ubuntu will provide a 64 EFI boot. This wont work, the EFI boot 64 bit is not seen by the MBP.

The solution that worked for me:

  • installing rEFInd from OSX
  • create a bootable USB to install a 32 bits linux kernel such as Debian 10.6 (Ubuntu 18.04 has also a 32 bit version).
  • Then from rEFInd, the system can boot from the bootable USB and proceed to installation.

Side-Note that, rEFInd 32 bits can boot a 32 bit bootable USB with a 64 bit linux kernel for installation. However, since installed, rEFInd is not able to load a 64-bit kernel. That is why GRUB replaces rEFInd for booting and loading.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .