1

I'm trying to install taskcoach on Ubuntu 20.04. It requires python2 and some other python2 dependencies.

I've tried to following the advices I've found at this link: https://answers.launchpad.net/taskcoach/+question/690591

but no success.

These are the steps I tried:

#install python 2
sudo apt install python2
#install pip (2)  https://linuxize.com/post/how-to-install-pip-on-ubuntu-20.04/
sudo add-apt-repository universe
sudo apt update 
sudo apt install python2
curl https://bootstrap.pypa.io/get-pip.py --output get-pip.py
sudo python2 get-pip.py
pip2 --version

#install dependencies 
sudo pip2 install twisted
sudo pip2 install notify
#Download taskcoach_1.4.6-1.deb 

#editing /var/lib/dpkg/status and deleting those two dependencies from the Taskcoach package
kate /var/lib/dpkg/status
#original line is: Depends: python (>= 2.6), python-wxgtk3.0 (>= 3.0.0.0), python-wxversion, python-twisted (>= 10.0), libxss1, ttf-dejavu, xdg-utils, python-igraph
new line I put is: Depends: python (>= 2.6), libxss1, ttf-dejavu, xdg-utils
sudo dpkg --force-all -i taskcoach_1.4.6-1.deb

I still get the following error:

sudo dpkg --force-all -i taskcoach_1.4.6-1.deb
    (Reading database ... 283484 files and directories currently installed.)
    Preparing to unpack taskcoach_1.4.6-1.deb ...
    Unpacking taskcoach (1.4.6-1) over (1.4.6-1) ...
    dpkg: taskcoach: dependency problems, but configuring anyway as you requested:
    taskcoach depends on python-wxgtk3.0 (>= 3.0.0.0); however:
    Package python-wxgtk3.0 is not installed.
    taskcoach depends on python-wxversion; however:
    Package python-wxversion is not installed.
    taskcoach depends on python-twisted (>= 10.0); however:
    Package python-twisted is not installed.
    taskcoach depends on python-igraph; however:
    Package python-igraph is not installed.

    Setting up taskcoach (1.4.6-1) ...
    Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
    Processing triggers for mime-support (3.64ubuntu1) ...

Basically the /var/lib/dpkg/status for some reason gets recreated with the old dependencies when I try to install that package..

Any hints?

1 Answer 1

0

It clearly states it depends on those packages, then why do you change the status file? The dependent packages should be added to fix this.

1
  • I just followed the instructions in the link above. It seems that those dependencies are not needed following those steps
    – veltres
    Oct 5, 2020 at 7:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.