Installed KDE Plasma desktop with

sudo apt install kde-plasma-desktop

Tried it for a few days and, while I liked it a lot, it's just not playing well with my current Ubuntu 20.04 installation.


  1. No screenshot app, hitting print screen does nothing
  2. Snap acting funny and can't be found through app launcher, have to run apps through terminal and pin them.
  3. $HOME/bin scripts aren't in PATH anymore for some reason
  4. And more..

Went back to Gnome and removed it with sudo apt remove --purge kde-plasma-desktop. But now I still have issues with 2 and 3.

How do I remove KDE plasma completely and restore my Gnome desktop to what it was?


Solutions here didn't work for me either.

  • 2
    There is a very good reason why Ubuntu comes in several different flavors with different desktop environments. It's because switching DE on an installed system is messy. There's dozens and dozens of packages that are switched out. You have more than 4 problems so I'd suggest a reinstall. In the future if you want to try out a DE, try the "Try Ubuntu" option from installation media – Nmath Oct 1 '20 at 16:05
  • 2
    FYI, none of these problems have to do with KDE or GNOME themselves. – Nmath Oct 1 '20 at 16:06
  • 2
    I agree with @Nmath above here. I have found some of the DEs don't play well with others when installed together. KDE/Plasma is one of them I found that doesn't like when you have others like I had Xubuntu as well. I ended up clean installing Xubuntu back on the system because KDE got its grip deep into my Xubuntu installation. – Terrance Oct 1 '20 at 16:16
  • If the 2 and 3 are your issues, you can 2. consider adding snap to /usr/local/applications 3. Add export PATH=$PATH:$HOME/bin to your ~/.profile. – MidwayNomad Oct 1 '20 at 17:22
  • Fully agree with @Nmath, your better off doing a reinstall if you want to do things cleanly, or else your basically playing a game of cat and mouse to find and really pinpoint packages and such. – samgabbay Jan 5 at 3:41
sudo apt remove plasma-desktop --autoremove
sudo apt remove kubuntu-desktop --autoremove
sudo apt-get remove kde* --autoremove
sudo apt-get remove plasma* --autoremove
sudo update-alternatives --config default.plymouth # select an option
sudo update-initramfs -u
sudo update-grub
sudo systemctl disable sddm
sudo systemctl stop sddm
sudo systemctl enable gdm3
sudo systemctl start gdm3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.