6

I recently updated to 20.04 and I love the new full range of full color emoji but they disappear when I print, export to PDF or even if I download a pdf from email.

I thought it was a libre office issue at first until I noticed them disappear from the downloaded PDF. In the screencapture is a Libre office spreadsheet print preview screen full of emoji, and on the right is what I get if I export to PDF or print.

screencapture

I have verified that "objects/images" is checked in LibreOffice, tried from a fresh file, and tried it in LibreOffice's safe mode. Please help.

4
  • It may depend on which app you view the PDF file with. This looks like the default Evince document viewer. Do the emoji appear if you open the file with your browser, or with LibreOffice Draw, or Gimp...?
    – Jos
    Oct 1, 2020 at 8:50
  • interesting. so if i open the pdf with chrome they disappear, but if i use LibreOffice Draw they are there. i did notice that my Printer Language type is "Automatic : PDF" Oct 1, 2020 at 10:50
  • i dont have gimp. but i did email the pdf to my wife whose windows computer did not display the emoji Oct 1, 2020 at 11:18
  • i installed and tried Atril Document Viewer with the same result. Oct 1, 2020 at 11:27

3 Answers 3

3

Until this bug is fixed, the work arounds seem to be exporting to PNG rather than PDF or replacing the emojis with symbols from the Symbola font (which are black and white).

1
  • Exporting as an image is not viable since there will be no hyperlinks available.
    – kissu
    Oct 7, 2022 at 0:24
0

A valid workaround consists in uploading the LibreOffice file (eg ODT) to Google Docs and printing from Google Docs.

Not satisfying, but working.

0

It was written that it is a bug:

https://bugs.documentfoundation.org/show_bug.cgi?id=129523

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.