9

I've been following a couple of tutorials to add ssl to my server (node application).

I tried installing Certbot with the following line on by Ubuntu 20.04 server:

sudo add-apt-repository ppa:certbot/certbot

but got a warning and no install:

This is the PPA for packages prepared by Debian Let's Encrypt Team and backported for Ubuntu.                                                                         
Note: Packages are only provided for currently supported Ubuntu releases.
More info: https://launchpad.net/~certbot/+archive/ubuntu/certbot
Press [ENTER] to continue or Ctrl-c to cancel adding it.*

After searching the net, there is mention of not using PPA, but to use an earlier standalone version - also mention of using snap - But I cannot find a concrete answer. I am using Express and not nginX.

Could someone suggest how to install, please?

Update

Ran sudo snap install certbot.

Result:

error: This revision of snap "certbot" was published using classic confinement and thus may perform
   arbitrary system changes outside of the security sandbox that snaps are usually confined to,
   which may put your system at risk.
   If you understand and want to proceed repeat the command including --classic.
1
  • 1
    That's not a command to install a package. Rather, sudo add-apt-repository ppa:certbot/certbot adds the certbot PPA to your list of trusted sources. Since you've added that to your sources, you may now install the packages they publish. After running that command, make sure to update by sudo apt-get update, and now you'll be able to install the packages they publish (they list them here: launchpad.net/~certbot/+archive/ubuntu/certbot/+packages) – user96931 Sep 30 '20 at 16:52
7

They have gotten rid of the apt it is now snap install certbot --classic

10
  • 1
    Sorry for the newbie question, which version does the above command install ? - is it called a standalone installation ? – Orange Juice Jones Sep 30 '20 at 17:14
  • @Jet I do not believe in bad questions! Now the answer to your question is: It will install the latest version – Nate Sep 30 '20 at 17:24
  • 1
    I found another command on Certbot website, 'snap install --classic certbot', Is thi applicable to my situation? Also after I ran 'sudo add-apt-repository ppa:certbot/certbot' as in my question, I checked folder /etc/apt/sources.list.d/ and can see a file called certbot-ubuntu-certbot-focal.list', Should I delete it ?. (I havent yet ran 'apt-get update') – Orange Juice Jones Sep 30 '20 at 17:36
  • 1
    Hi, ran 'sudo snap install certbot' and received error and the use of --classic . I've updated the question. – Orange Juice Jones Sep 30 '20 at 17:52
  • 1
    Express and NodeJs only – Orange Juice Jones Sep 30 '20 at 18:24
-4

It appears you've gotten mixed up a little bit. The easiest way to install Certbot is by using Certbot-install on Github, like so:

curl -o- https://raw.githubusercontent.com/vinyll/certbot-install/master/install.sh | bash

and voilla, you have it installed.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.