0

I recently purchased an Acer Aspire 5 A515-55g. I created an Ubuntu 18.04 dual-boot with Win 10. My hard drive is a hybrid HDD (1TB) & SSD (256GB).

PROBLEM

The core problem is that Ubuntu does not recognize my home folder partition when I boot.

Instead, Ubuntu creates new default "home" folder at /home with default settings, ignoring files & settings that were placed on the "home" partition user directory.

Also I am unable to successfully open gparted...it just hangs trying to determine what partitions are available. Ubuntu's "disks" application recognizes all partitions and seems to work normally.

Actions

1.) I split up my SSD between Win10 & Ubnutu 18.04.

2.) Then, I partitioned the 1TB HDD (835GB ext4) and then

3.) I used official Ubuntu Home Partition Guide to move my "home" folder to a "home" partition.

4.) I renamed the default home folder as instructed, I removed /media/home , finally I reboot the machine... completing the instruction guide above.

Problem (cont)

However, after reboot, when I login Ubuntu has created what appears to be a new default home folder, ignoring my files & settings that I restored to the "home" partition.

"Troubleshooting"

I installed "finger" and ran sudo finger my-user-name OUTPUT:

Login: my-user-name             Name: My Name Directory: /home          Shell: /bin/bash On since Wed Sep 30 15:26 (CST) on :0 from :0 (messages off) Mail last read Tue Sep 29 03:21 2020 (CST) No Plan.

This looks like it points at the default home folder.

QUESTION(s) How do I get Ubuntu to point at correct "home" partition containing my files and settings? I

2
  • Are you sure your fstab entry for new /home partition is correct? post this: cat /etc/fstab and lsblk -o name,mountpoint,label,size,fstype,uuid | egrep -v "^loop" – oldfred Sep 30 '20 at 14:28
  • I figured out happened... will post an answer – yupthatguy Oct 2 '20 at 2:40
0

I solved the problem..

1.) The Ubuntu Home Partition Guide worked correctly.

  • I mistakenly thought it worked incorrectly because because only part of my restored files & settings were available (making me believe that the smaller SSD Drive had simply run out of space and prematurely terminated my rsync command)

2.) I booted into a live session and checked out the home partition. And sure enough, it also had only partial amounts of my files and settings. Meaning that the problem was some mysterious "malfunction" of rsync command that was supposed to restore my files & settings.

3.) Therefore, on the home partition I:

a.) rsync my files and settings, again.. into a folder with username b.) I confirmed that the home folder was set to my user folder user folder
/home/dragonpharaoh using the usermod command c.) I booted up and "presto" all was well.. @oldfred thx.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.