2

I installed Ubuntu 20.04.1 today itself alongside Windows 10, my Asus ROG GL503 laptop. It was working fine until the Software Updater had some updates. When it got completed and restarted, there was no sound when I connect my earphones. And when I tried a few solutions now, there is no sound coming from the laptop internal speakers.

When I boot into Windows, there is no sound when I connect my earphones, but Internal Speakers work.

Solution:
Paste this line at the end into file /etc/modprobe.d/alsa-base.conf then SHUTDOWN the system, DO NOT reboot.

# Audio fix for asus GL503 with Intel Corporation CM238 HD Audio Controller (ACL295)
options snd-hda-intel model=dell-headset-multi

https://forum.manjaro.org/t/sound-from-speakers-no-sound-from-3-5mm-jack-audio/5343/28

4
  • Crackling and popping is probably not a software issue. I suggest that you try those headphones on another device. Then try different headphones on this device. By process of elimination this should determine whether or not it's the headphones or the port that is bad. – Nmath Oct 3 '20 at 19:27
  • @Nmath It's working fine on my Windows 10. – Saurav Oct 4 '20 at 6:37
  • Crackling and popping maybe due power saving feature. Check this post for possible solution: superuser.com/questions/1493096/… – Gustavo Garcia Jan 13 at 17:12
  • @GustavoGarcia I moved onto PopOS and it solved the crackling and popping – Saurav Jan 14 at 7:33
1

I had same problem with asus GL703GM.

The fix was to edit /etc/modprobe.d/alsa-base.conf and add the this line at the end:

options snd-hda-intel model=headset-mode

When done editing, shutdown the system completely (do not restart).

However the headset mic didn't work, but it ok with me as the internal laptop mic was OK.

Original post: (Ubuntu 20.04 headphones detected but no sound)

you may read the https://forum.manjaro.org/t/sound-from-speakers-no-sound-from-3-5mm-jack-audio/5343/20 link thread for better solutions.

6
  • I followed this and thankfully there is sound in my earphones as well as in Windows 10. But the microphone in my earphones isn't working but they are working in Ubuntu. Any solution you found? – Saurav Oct 4 '20 at 20:40
  • Add this instead options snd-hda-intel model=dell-headset-multi. Both should work fine when choosing Headset option when you plug earphones – Saurav Oct 31 '20 at 5:50
  • For Microphone, put this line in the alsa-base.conf file: options snd-hda-intel enable_msi=1 and then on terminal issue this: sudo rmmod snd-hda-intel && sudo modprobe snd-hda-intel. Then shutdown (don't restart). – Arijit Chatterjee Jan 13 at 4:34
  • Any difference on dell-headset-multi and headset-mode? Using dell-headsset-multi when i connect a headset on jack it asks if it is microphone, headphones or headset. – Gustavo Garcia Jan 13 at 17:11
  • @GustavoGarcia I used dell-headset-multi in PopOS and by selecting Headset it allows microphone on your headset and if you select Headphones it doesn't allow microphone on your headset rather it uses the microphone on your Laptop – Saurav Jan 14 at 7:34
0

I had a very similar problem on my Dell laptop, especially when running Audacity.

The snd-hda-intel model=dell-headset-multi config looked promising but it didn't work. At first I thought I had solved it by reverting an update of alsa-utils. I went back from 1.2.2-1ubuntu2 to 1.2.2-1ubuntu1 using Synaptic Package Manager. This update came out a few days after your question so I guess my issue is not exactly the same as yours.

aplay -l lists ALC3204 as my audio device in case someone needs this info.

When running alsa-utils 1.2.2-1ubuntu1, Audacity is kind of picky with audio devices but I can unplug and then plug my earphones in again to make everything work.

When running the 1.2.2-1ubuntu2 version however, plugging my earphones/headphones simply doesn't work. They are detected but no sound comes out. If I manage to get some sound (after rebooting a few times), then Audacity ruins everything leaving me with no sound on the 3.5mm jack again.

It seems that the problem manifests itself more clearly when booting with earphones plugged in and reconnecting the earphones while the settings app is open. Otherwise it might work correctly on either alsa-utils version, but 1.2.2-1ubuntu1 looks much more stable/predictable so I'm sticking to that version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.