3

Using Ubuntu 20.04 on a XPS 15 9560, I installed the system76-power package to disable the GPU at will as I don't need it 90% of the time. It worked flawlessly for a few months but now I have a conflict between it and a nvidia-prime package (probably coming from the nvidia-driver-440/focal-updates 450.66-0ubuntu0.20.04.1).

$ sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 system76-power : Conflicts: nvidia-prime
E: Broken packages

How do I fix this conflict?

I should mention I can't upgrade with apt as it's blocking the overall process (I could upgrade individual packages, but I'd prefer fixing the issue first).

I have no memory installing nvidia-prime but it might have been auto-installed by the driver utility.

2 Answers 2

2

Remove nvidia-prime with sudo apt remove nvidia-prime. If system76-power depends on it (it looks like it) remove both. If you've removed both: upgrade the system and reinstall system76-power, else upgrade only.

I'd always try not to use any force flags..

2
  • 2
    After checking for uninstalling nvidia-prime, turns out it wasn't installed as I assumed. Nevertheless I went your way and 1) removed system76-power 2) let nvidia-prime install itself with the system upgrade, then 3) reinstalled system76-power and apt automatically removed nvidia-prime. Weird fluke but everything seems back to normal. Thanks! I seem to have lost the ability to start a Wayland session but I don't mind as some things weren't working right with it. Sep 29, 2020 at 23:04
  • @ChuckMaurice Consider adding your response as an answer. It solved my problem.
    – BenR
    Nov 18, 2020 at 19:17
0

When I did sudo apt remove system76-power, I got the following:

Reading package lists... Done Building dependency tree
Reading state information... Done The following packages were automatically installed and are no longer required: fd-find gnome-shell-extension-alt-tab-raise-first-window gnome-shell-extension-always-show-workspaces gnome-shell-extension-desktop-icons-ng gnome-shell-extension-pop-shop-details libqalculate20 libqalculate20-data pop-gnome-shell-theme pop-gtk-theme pop-icon-theme pop-launcher pop-shell pop-shell-shortcuts pop-sound-theme pop-theme qalc Use 'sudo apt autoremove' to remove them. The following packages will be REMOVED: gnome-shell-extension-system76-power pop-default-settings pop-desktop pop-session system76-power WARNING: The following essential packages will be removed. This should NOT be done unless you know exactly what you are doing! pop-desktop pop-session (due to pop-desktop) pop-default-settings (due to pop-desktop) 0 upgraded, 0 newly installed, 5 to remove and 354 not upgraded. After this operation, 2,860 kB disk space will be freed. You are about to do something potentially harmful. To continue type in the phrase 'Yes, do as I say!'

I decided against doing it since it would uninstall the full desktop.

Thoughts?

Thanks, Ron

2
  • Yes here is a thought how is this an ANSWER to the question asked.
    – David
    Feb 24 at 5:38
  • 1
    If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. - From Review
    – David
    Feb 24 at 5:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.