Possible Duplicate:
Enabling Nvidia driver messes up splash screen

How I can change the boot screen resolution in Ubuntu 12.04 to 1680 1050? The resolution now is very small

  • 1
    – Anake
    Apr 29 '12 at 16:09
  • @Anake Actually, this question make sense since the provided answers in the first topic linked ("enabling nvidia driver messes splash screen") are too old, now we're talking about 17.10 and the answer below (which really helped me) is the most correct, unlike those answers in the above mentioned topic, made for older versions of Ubuntu. Nov 26 '17 at 19:14
  • @JKandy-drew That question was asked in 2012, and I wrote that comment in 2012 .....
    – Anake
    Nov 27 '17 at 7:47
  • @Anake Sorry, I didn't intended to blame you at all, I was just asking why this question was flagged (or un-flagged afterwards), when it was useful instead, since the old question was for an older OS. That's all. Nov 28 '17 at 14:36

Try this:

  1. We will have to edit grub configuration. Open a terminal and paste this:

    sudo gedit /etc/default/grub

    Hit Enter. It will open grub preferences in Gedit.

  2. Locate the line # GRUB_GFXMODE=800x600 (resolution may be different).

You have to change the resolution to actual resolution of your screen, for example mine is 1240x1024. Next step is to uncomment this line (remove the # and and the empty space if is, so the letter G of the word GRUB will be the first letter in this line). After u r done, save the file and close.

3 . Now paste this line in terminal:

sudo gedit /etc/grub.d/00_header .

Hit Enter. It will open a text file with a lot of stuff. Use the search option at the top of the window to locate this line:

set gfxmode=${GRUB_GFXMODE}

After you successfully find it, you will have to add this line: set gfxpayload=keep just under the . Make it look like this:

set gfxmode=${GRUB_GFXMODE}
set gfxpayload=keep

Now, save the file and close.

4 . In terminal paste:

sudo update-grub 

Hit Enter, it will generate new grub.cfg file so the changes you made will be saved.

Reboot and enjoy your new boot screen resolution.

In case you don't know what is your screen resolution

Go to System settings - Displays

  • Thanks a lot, I think it's the best answer for (my) Ubuntu 17.10. Nov 28 '17 at 14:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.