0

My VPN stopped working 2 days ago after installing Ubuntu software updates. I have Ubuntu 20.04.1 LTS I was prompted to install updates and did so on Sept 24 or 25, 2020.

Since letting the updtes automatically install I cannot connect to a VPN. I have Surfshark. I enter ...

sudo surfshark-vpn

I get ...

Checking for connection status...
Not connected to Surfshark VPN
Was unable to connect to VPN server. Please try another server.

I also have Protonmail VPN. When I start is with ...

sudo protonvpn connect

I get ...

Connecting to JP-FREE#2 via UDP...
[!] There was an error connecting to the ProtonVPN API.
[!] Please make sure your connection is working properly!

I have another Ubuntu computer on the same home network. It is running 18.04 LTS. I have no such issues with that laptop.

Thanks in advance...

2

I cannot answer why exactly is it not working anymore, I had the same issue though.

What I did to fix it:

sudo surfshark-vpn forget
sudo surfshark-vpn
1

Not sure if you solved it yet, but in case anyone else has the same problem, this is how I got it back up. I got it working by uninstalling network-manager-openvpn, network-manager-openvpn-gnome, and openvpn-systemd-resolved. This also gets rid of OpenVPN and Surfshark itself, so the two packages need to be reinstalled afterwards. There is some conflict with these packages, apparently.

2
  • This is not an answer. There is no evidence that what help you will help others too. I would recommend to look in systemlog first. Please post output of journalctl here. Dec 20 '20 at 14:53
  • Yeah, I added that to the bug report that Joe did on Launchpad. Thanks for the suggestion! bug 1899410
    – Tizi
    Dec 22 '20 at 22:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.