0

My hard drive is partly visible (only 4.1 GB of 2TB) in "Disks" and has a bad sector. I have tried using the smartmontools to check for bad sectors and then used badblocks -svn /dev/sda for which I get the response

badblocks: Permission denied while trying to determine device size

Then I tried to use installation utility but the 18.04 LTS stops responding at selecting language.

error starting SMART self test

"Disk is OK, one bad sector"

Edit 3: New development in the issue - the live usb has started to become unresponsive/ freezing.

Edit 4: using the method provided by 1st answer I am getting the error shown:

Gparted: input/output error during read of /dev/sda

error fsyncing/closing /dev/sda

fdisk output - can't see the disk

  • This doesn't look very good. I hope you have good backups. Go ahead and try doing my answer. Report back. I'm going to bed now, but send me a comment, and I'll return in the morning. – heynnema Sep 27 at 2:56
  • Hey @heynnema, I tried your method but it didn't work. I have added an image for it. Right now I have installed 20.04 LTS on another drive and tried to repeat the smart scan process, but the result was same and there is some error related to input/output of the disk. – Someone. Sep 27 at 11:11
  • You gave it an incorrect command. It's not /dev/sda. Please re-read my instructions and report back. – heynnema Sep 27 at 12:13
  • The commands given that you provided did not return a number for that hard drive. Please, is there any other way ? @heynnema – Someone. Sep 27 at 15:43
  • Show me the output of the sudo fdisk -l command. Do you have backups of the data on this drive... or do you, at this point, care about anything on this drive? If not, we'll lay down a fresh GPT partition table (this will wipe the drive), then we'll install a fresh ext4 partition, then we'll bad block it. – heynnema Sep 27 at 15:55
2

The Disks, fdisk, and gparted screenshots don't look very promising...

fsck

First check your file system.

  • boot to a Ubuntu Live DVD/USB in “Try Ubuntu” mode
  • open a terminal window by pressing Ctrl+Alt+T
  • type sudo fdisk -l
  • identify the /dev/sdXX device name for your "Linux Filesystem"
  • type sudo fsck -f /dev/sdXX, replacing sdXX with the number you found earlier
  • repeat the fsck command if there were errors
  • type reboot

bad block

Note: do NOT abort a bad block scan!

Note: do NOT bad block a SSD

Note: backup your important files FIRST!

Note: this will take many hours

Note: you may have a pending HDD failure

Boot to a Ubuntu Live DVD/USB in “Try Ubuntu” mode.

In terminal...

sudo fdisk -l # identify all "Linux Filesystem" partitions

sudo e2fsck -fcky /dev/sdXX # read-only test

or

sudo e2fsck -fccky /dev/sdXX # non-destructive read/write test (recommended)

The -k is important, because it saves the previous bad block table, and adds any new bad blocks to that table. Without -k, you loose all of the prior bad block information.

The -fccky parameter...

   -f    Force checking even if the file system seems clean.

   -c    This option causes e2fsck to use badblocks(8) program to do
         a read-only scan of the device in order to find any bad blocks.
         If any bad blocks are found, they are added to the bad block
         inode to prevent them from being allocated to a file or direc‐
         tory.  If this option is specified twice, then the bad block scan
         will be done using a non-destructive read-write test.

   -k    When combined with the -c option, any existing bad blocks in the
         bad blocks list are preserved, and any new bad blocks found by
         running badblocks(8) will be added to the existing bad blocks
         list.

   -y    Assume an answer of `yes' to all questions; allows e2fsck to be
         used non-interactively. This option may not be specified at the
         same time as the -n or -p options.

Update #1:

The HDD is defective. Replace it. It may still be under warranty. Check with Seagate.

| improve this answer | |
0

Conclusion: The Hard Drive is destroyed ( useless and cannot be repaired ). So if anyone one is facing similar problem, check if any solution mentioned in the comments work for you or ask a new question on the forum.

| improve this answer | |
  • I added this info to my answer. – heynnema Sep 28 at 18:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.