1

I am running Xubuntu 20.04 on amd64.

When I installed a Korean keyboard layout ("input method") through IBus, a small window appeared on my screen.

ibus-ui-gtk3 property panel window

Using xwininfo I found that this window is titled "ibus-ui-gtk3".

The window has options relating to the Korean input method (e.g. a button to toggle between hangul and hanja). However, the window never goes away, even when I switch to a different input method (e.g. English).

How do I make this window go away, or at least only show up when using the Korean input method?

2

I solved this issue by opening "IBus Preferences" (ibus-setup from CLI) and changed the "Show property panel:" option in the "General" tab to "Do not show".

Now the "property panel" (as I now know it is called) is not present. There is also a "Hide automatically" option that seems to make the window only show up when you start typing.

"IBus Preferences" window with the "Show property panel" option set to "Hide automatically"

3
  • The default value of that setting should be "Do not show". Had you changed it previously? – Gunnar Hjalmarsson Sep 26 '20 at 23:50
  • @GunnarHjalmarsson No, I don't think I changed it manually. The window popped up the first time I switched to the Korean input method. Now that I have had the setting set to "Hide automatically" for a while, it seems that the window pops up whenever I click into some text box (e.g. url bar in firefox), even with the English input method, so I will probably change it to "Do not show". – pizzapants184 Sep 27 '20 at 3:24
  • I see. Good that you figured out the applicable setting anyway. – Gunnar Hjalmarsson Sep 27 '20 at 5:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.