0

I am trying to install arm toolchain and my programming teacher gave me instructions how to do it. I extracted the downloaded libraries in /opt and I tried to create links in /usr/local/bin pointing to /opt/gcc.../bin/*file

The command he gave me:

sudo ln -s opt/gcc-arm-none-eabi-9-2019-q4-major/bin/arm-none-eabi-gcc /usr/local/bin/arm-none-eabi-gcc

Then I checked the version with:

arm-none-eabi-gcc --version

but it said that it's not installed. I looked into /usr/local/bin with midnight commander and the link was red: !arm-none-eabi-gcc

I checked, I wrote everything correctly. I'm thinking maybe I downloaded an incorrect version of the toolchain from the arm website.

Can someone help me? Thank you!

  • 6
    You want a leading / there. Without it, the path is relative – muru Sep 25 at 14:27
  • It solved my problem! I appreciate your help! – cseha Sep 25 at 15:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.