1

I've tried searching for answers but haven't come up with anything useful.

I installed Ubuntu about a month ago on my desktop computer. It has worked great initially, but just the other day my main monitor has now stopped being detected completely. I've read about the monitor maybe being deactivated or such, but I can't find it anywhere.

I've tried unplugging it and plugging it in again after restarting and that didn't work. I've tried installing ARandR but it doesn't detect my other monitor.

I dual boot my computer with Windows and it has no problem detecting my monitor as normal, which is really strange. I didn't do anything in particular before I got this problem, like install an update or such, so it's strange that it just suddenly stopped working.

Pleas help! I use Ubuntu for school and I think it works better than Windows for what I'm doing. It sucks that things just stop working for apparently no reason.

Edit: Output from xrandr --listmonitors: xrandr: Failed to get size of gamma for output default Monitors: 1 0: +*default 1920/508x1080/286+0+0 default

Edit: RESOLVED

  • Open a terminal CTRL+ALT+T and type this command: xrandr --listmonitors Please post the output. – koni_raid Sep 25 at 13:12
  • xrandr: Failed to get size of gamma for output default Monitors: 1 0: +*default 1920/508x1080/286+0+0 default – Gaennil Sep 25 at 13:18
  • So only one Monitor is shown! Cable should not be the problem, as it works with Win, correct? What type of Monitor? Which Graphic card? What type of Desktop PC? See also this post: askubuntu.com/questions/1105332/… – koni_raid Sep 25 at 13:27
  • When I run lspci | grep VGA it says: 01:00.0 VGA compatible controller: NVIDIA Corporation GK104 [GeForce GTX 760 OEM] (rev a1). My monitor has a few years on its back but it worked fine just a few days ago. It's an LG Flatron E2441. My computer is quite old (it's an Acer Predator from at least 5 years back if not more) but I haven't had any major issues with it. And yes, it works fine with Windows so the cable is not the problem. – Gaennil Sep 25 at 13:34
1

I had a similar issue like this. I downloaded and selected the proprietary drivers I needed in software&updates->additional drivers, and did a couple of restarts. You can check which driver you need with:

ubuntu-drivers devices

Select the right one and restart. It should resolve itself. If that doesn't work try this:

sudo apt-get purge 'nvidia*'
sudo add-apt-repository ppa:graphics-drivers
sudo apt-get update
sudo ubuntu-drivers autoinstall
| improve this answer | |
  • How do I know which proprietary drivers I need? Currently it says "Using NVIDIA driver metapackage from nvidia-driver-450 (proprietary, tested)". – Gaennil Sep 25 at 13:37
  • Check edit above. – Mike Rawding Sep 25 at 14:19
  • Thank you! Typing "ubuntu-drivers devices" listed a bunch of different proprietaries, but after I switched to another one it works just like before. I swear I had the same one selected when everything got messed up as well, but I'm not sure. It worked at least, so I'm glad! – Gaennil Sep 25 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.