1

How can I get apps to open the actual web pages they're meant to?

Anything I click on in an app that's supposed to open a web page opens a file:// URL in the default web browser instead.

Some examples:

  • Open Minecraft and click on the "Buy now!" button:
    file:///home/vince/.cache/kioexec/krun/29598_0/unnamed
  • Open any LibreOffice app and click on "Website" in the About window:
    file:///home/vince/.cache/kioexec/krun/29661_0/en
  • "Tips and Tricks" from the Help menu in VSCode:
    file:///home/vince/.cache/kioexec/krun/30675_0/unnamed

The pages look like they've been retrieved from the web without the resources that would've been accessible if they were loaded from the web. For example, the file loaded for LibreOffice is just an HTML file named "en" (no extension) and it attempts to load CSS files from /themes/libreofficenew/css

These folders in ~/.cache/kioexec/krun go away after they're viewed, but not immediately. I'm guessing something cleans up that directory periodically.

This may only be affecting KDE (Qt?) apps. It doesn't happen in GIMP when I click "Main Website" from Help → GIMP Online.

  • Are you running wine? – SimpliFixed Sep 25 at 19:42
  • No. I rarely need to run any Windows apps, but when I do I use VirtualBox. I actually contacted Microsoft to transfer my Win10 license from my laptop (which I've also installed Kubuntu on) to my virtual machine. – Vince Sep 26 at 1:15
  • Related problem here with links in Konsole. I start my browser with a script necessary to switch to a different browser profile. Setting it as the default browser does not help. It always opens with the in this issue explained path and opens the site, but since the URL is wrong all links /path links will be broken because there is no decent domain. Since I use a Docker environment with its own CA the TLS links fail to open because KDE does not allow to pre-approve CA-certificates. Should it not simply do what I tell it and open it with my custom script? – ñull Oct 27 at 12:05
0

I found this bug report which described the same problem.

One of the first few suggestions was to check System Settings → Applications → Web Browser and change the setting from in an application based on the contents of the URL to explicitly choose a web browser.

I'm using Firefox Developer Edition which I've installed manually because they don't have a Debian package for it. My web browser was set to with the following command and I had selected the menu entry (.desktop file) I created for the browser.

I changed the setting to "in an application based on the contents of the URL" (basically, the opposite of the recommendation in the bug report) and the problem went away. I think this only worked because I've already set Ff Dev Edition as my default browser with update-alternatives and in a few configuration files I don't remember off the top of my head.

This fixed the problem, but there are still some unanswered questions:

  1. Why would it download a web page before opening it, regardless of the setting?
  2. How do I add a manually installed browser to the drop-down under the in the following application option?
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.