Working on an Asus K550L, just installed Ubuntu 20.04. When I close the lid, I have the setting all set to suspend. I've done it in Tweaks, and I've set it in logind.conf as well, but the computer keeps powering off and I have to reboot. I also have Windows installed, not sure if that plays a role. Thank you in advance for any advice.

Here are the settings:


1 Answer 1


The # symbol at the beginning of the line means "ignore this line". Remove those # symbols to have the settings take effect.

Edit: It's recommended to leave the # symbol on lines that you don't care about, so if the defaults ever change, you'll get the new default for that setting.

  • Thank you Jasonwoof. I get a Tepl warning that says "GVfs metadata is not supporte supported. Fallback to TeplMetadataManager. Eirther GVfs is not correctly installed or GVfs metadata are not supported on this platform. In the latter case, you should configure Tepl with --disable-gvfs-metadata." I removed the hashtags, saved, and rebooted. Still powering off when I close the lid instead of suspending.
    – Chefdaddy
    Sep 29, 2020 at 0:45
  • Does your suspend work when you trigger it manually? What about hibernate? I would try setting the last two actions to suspend (maybe your laptop is sending PowerKey or Hibernate key when you close it). Then if that doesn't work, set all to "ignore". Maybe logind.conf isn't in control.
    – JasonWoof
    Sep 29, 2020 at 1:34
  • So you're correct - suspend doesn't work when triggered manually, it also reboots the computer then as well. What can I do to diagnose this issue?
    – Chefdaddy
    Oct 27, 2020 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.