So I proudly updated my Linux distro for the first time and thereafter got a problem. I'm running Ubuntu Unity 2D (usually) 12.04 (since today) on a 64 bit computer.

Indeed, the first upgrade -- I made the upgrade through the Update Manager -- was okay (even if I was surprised by the amount of i386 packages that had to be installed).

Then, I re-enabled the repositories that had been disabled because of the upgrade and updated my system. I was told to perform a 'Partial Upgrade', that I did, but was once again surprised by the amount of i386 packages installed and also by the fact that LMMS (https://launchpad.net/lmms) was being removed; Wine, among others, was also being updated and that's probably the reason because LMMS depends on certain versions of Wine (I just know this, for the rest I'm a total noob). Anyway, this leaded me to the broken dependencies gstreamer0.10-plugins-good:i386 and libasound2-plugins:i386. Synaptic also constantly tries to install libjack-jackd2-0:i386, but each time it gets an error. I don't know if all this is Wine or LMMS related, but it maybe can help...

I was told to perform: 'sudo apt-get -f install' by Synaptic but it apparently failed:

    ~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libxml++2.6-2 librtaudio4 libx264-116 libfluidsynth1 lmms-common librtmidi1
  wine-gecko1.4 wine-gecko1.4:i386 libffado2 stk libconfig++8 libstk0c2a
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
Suggested packages:
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/202 kB of archives.
After this operation, 493 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 249517 files and directories currently installed.)
Unpacking libjack-jackd2-0:i386 (from .../libjack-jackd2-0_1.9.8~dfsg.2-1precise1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libjack-jackd2-0_1.9.8~dfsg.2-1precise1_i386.deb (--unpack):
 './usr/share/doc/libjack-jackd2-0/buildinfo.gz' is different from the same file on the system
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Must I remove those broken packages via Synaptic? I would like to understand that problem as I can't install anything new from the Software Center. Thanks everyone!


That's a bug in the libjack-jackd2-0 package, version 1.9.8~dfsg.2-1precise1 (which isn't a version ever published in Ubuntu, must have come from somewhere else). It claims to be Multi-Arch: same, but that file differs between architectures.

You can almost certainly safely delete /usr/share/doc/libjack-jackd2-0/buildinfo.gz, after which APT should be happy:

sudo rm /usr/share/doc/libjack-jackd2-0/buildinfo.gz
| improve this answer | |

I ended up just renaming




and then ran

sudo apt-get -f install

Came up happy and no more broken packages messages.

| improve this answer | |

You need to reenable the mediabuntu repository which was disabled on your upgrade. At least that worked for me. Find the file that refers to mediabuntu in /etc/apt/sources.list.d, edit it (root), and take the # signs off the starts of the lines. Then update your repositories and do an upgrade. Problem solved for me.

| improve this answer | |
  • 2
    Thanks for the reply! I tried to search for mediaubuntu but didn't find anything so I just decided to remove the broken packages with (unfornately) one dependency package along which was useful to me (zsnes, a SNES gaming console emulator) and it worked. Then, I ran sudo apt-get autoremove and it got rid of all the weird i386 packages that had been installed, making some disk space. Everything works fine now! Thanks anyway! – SyS Apr 30 '12 at 11:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.