6

Running Ubuntu 20.04. This past Monday it updated to the Nvidia 450 driver (1080 Ti). At first, apt upgrade just removed the 440 driver and refused to install the new one, but in the additional drivers utility I was able to install the new 450 driver. Since installing it, the HDMI audio stops working and the option to select it as an output device disappears when I lock my screen (Meta (windows key) + L) and unlock with my password. A reboot recovers the HDMI audio. Anyone know what's going on/how to fix? SPDIF never stops working.

Thank you,

Derek

4
11

Same issue here. When it happens, I stop PulseAudio with a terminal command:

pulseaudio -k

PulseAudio then restarts automatically and works again until the next time.

1
  • 1
    Yes this works, but it's not a nice user experience :) Everything worked (mostly) fine with previous Ubuntu 18.04 and/or previous nvidia drivers. However I did have the same problem with nvidia-340 back and forth in older Ubuntus. So it's definitely not a problem unique to nvidia-450.
    – BjornW
    Dec 17 '20 at 2:34
6

I discovered the same issue. I run Ubuntu 20.04 with KDE.

I updated the Nvidia driver from 440 to 450; now if I lock my computer & turn off my screens (one is a TV connected with HDMI), the next time I turn the screens on & unlock my computer there is no output device.

Yes, a reboot will fix this. But at least in my case it looks like the problem actually is that PulseAudio can not recover the configuration, respectively the profile.

If I re-enable the profile manually as follows the output device works again:

  1. open "PulseAudio Volume Control"
  2. open the tab "Configuration"
  3. enable the "Profile" (checkbox) for your "High Definition Audio Controller" & select the correct available HDMI output.

I hope this helps a bit, so you don't need to reboot your computer to fix your sound issue.

I will continue to search for a final solution, but for now this is the only information I can provide.

Kind regards

1
  • 1
    Thank you! I installed with 'sudo apt install pavucontrol', followed your other instructions and it is so much more convenient than rebooting! Thank you!
    – Derek
    Sep 28 '20 at 14:37

Not the answer you're looking for? Browse other questions tagged or ask your own question.