Original Post

Hardware: Dell XPS 9360

Software: Ubuntu 20.04 (LTS)

Problem: Graphical Glitches when using Ubuntu's Desktop: Corrupted Icons with random artifacts each reboot, corrupted wallpaper with random artifact each reboot, missing character from fonts used in the desktop UI (taskbar and program menu) Screenshots:

Longer Explanation I recently did a fresh install of the new Ubuntu LTS after years of using an old versions. Everything worked fine. Then I began to setup my i3wm (which works fine without glithces) and so on, which I usually work with most of the time. After everything was setup, I switched back to the Ubuntu UI for a second and noticed the above states graphical/rendering problems. I tried googling them, but alltough I did find some older post, they either weren't answered or it turned out that after some investigation their problems didn't relate to mine. All I did during the setup was install normal apt stuff and mess around with my i3 and vim configs. The "most unusual" thing I did was setup some X11 stuff to get the touchpad and backlight working in i3, which I doubt messed up the ubuntu desktop like this (if it helps, here is everything i did: X11 stuff).

Does anybody have any idea how to fix the ubuntu-desktop without a total reinstall?

Already tried:

  • Rebooting
  • Restarting the Ubuntu UI (Alt+F2, r)
  • reinstalling ubuntu-desktop (sudo apt get install --reinstall ubuntu-desktop, then restart)


Update 1: Okay, so I should have tried this beforehand (sorry for that). Deleting the "90-touchpad.conf" and what i did in "xorg.conf" was apperently linked to the problem, which is more or less solved now. Could somebody explain to me what exactle happened here and if there is a way to use these workarounds for i3 without breaking ubuntu-desktop?

Update 2: After some investigation it turns out that the problem lies with the entry in xorg.conf and not the touchpad file. Now to try to find out what breaks it exactly.

Update 3: So after some messing around here are my conclusions: If I understand the xorg log files correctly my system automatically chooses the "modesetting" driver option. The above changes to the "Device" section in the config file which was needed to get xbacklight to work however specify the "intel" driver setting. Although I have "Intel Graphics HD 620", this driver appears to cause the rendering issues described above. A solution would most likely involve updating the intel drivers (or looking for a version which doesnt cause issues). An easier solution was to remove the changes to the xorg.conf file and use brightnessctl instead. Not really a solution to the question, but a work around for those who need it. Install it through "sudo apt install brightnessctl" and then reboot. If it is not working, try installing "sudo apt install brightness-udev" (which is needed for brightnessctl, but normally installed with the first package I think) and then reboot (important). You can find out how to control brightnessctl through the man page.

  • Nice to see yourself finding a solution :-). If you find the culprit, do not hesitate to write out your updates into a full answer and accept it: this is perfectly fine on this site and useful for other users. It must indeed be a specific problem related to your interventions, because normally that laptop runs perfectly with Ubuntu. I hope you can pinpoint the exact line causing the issue. (actually, I think by default Ubuntu does not use/have xorg.conf, so especially look for the lines related to display there (your interventions for the backlight!)
    – vanadium
    Sep 22, 2020 at 19:30

1 Answer 1


As suggested above, I will try to summarize my investigations into this problem as a standalone answer.

The above mentioned problems appear to be rendering issues stemming from the "Driver" part of the Device section included in the xbacklight fix to the xorg.conf file.

From the xorg log files (if I understood them directly) I gathered that instead of the "intel" driver option that is needed in the above fix to get xbacklight to recognize the display my system natively loads the "modesetting" driver option. Setting the above xorg.conf changes to "modesetting" solves the rendering issues (which are probably caused by old/unstable drivers that are called by the "intel" option), but breaks the xbacklight fix. I did not try updating my intel drivers, but I would assume this to fix the problems.

A workaround is to use brightnessctl instead of xbacklight. Install it through sudo apt install brightnessctl and then reboot. If it is not working, try installing the needed udev rule through brightness-udev (sudo apt install brightness-udev) and rebooting.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .