4

I just bought a new laptop called Asus ROG Strix G15 G512LW with i7 and Nvidia RTX, but there is no sound at all. Here are some of my device information:

$ cat /proc/asound/cards

 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xc5418000 irq 155
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xc5080000 irq 17

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC294 Analog [ALC294 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I have tried to select HDA Intel PCH from alsamixer and check if there are any muted selection.

Moreover, thanks to this thread on snd_hda_intel options I tried by adding the ones that listed below to the the alsa base:

$ sudo gedit /etc/modprobe.d/alsa-base.conf

options snd-hda-intel model=g50v
options snd-hda-intel model=g71v
options snd-hda-intel model=dell
options snd-hda-intel model= asus-a7j
options snd-hda-intel model=asus-a7m
options snd-hda-intel model= asus-laptop
options snd-hda-intel  model=lenovo

But whatever I tried I cannot made it to hear anything.

BTW when I wrote alsamixer and hit Enter I got this message:

$ alsamixer
cannot open mixer: No such device
So I reached it by writing `alsamixer -c 0` and its version is AlsaMixer v1.2.2

It's been a week that I have tried to solve it as a newbie in Ubuntu, so I thought it would be a wise decision to ask your help.

4
  • Do your built in speakers show up in System settings>>>Sound>>>Output? – Raffles Sep 20 '20 at 11:34
  • It is written as "Speakers - Built-in Audio" corresponds to Output device – unaidx Sep 20 '20 at 11:47
  • There are some more suggestions at this link – Raffles Sep 20 '20 at 12:12
  • I tried them all, but still it does not fixed.. – unaidx Sep 20 '20 at 12:34
5

On a Asus ROG Strix G17 G712LU-H7009T / Linux Mint 20 (Cinnamon), I faced the same problem (as many Linux users with ALC294 sound chipset). By setting :

options snd-hda-intel model=asus-zenbook

...in /etc/modprobe.d/alsa-base.conf, I was able to have sound on headphones and internal speakers, but the sound volume does not work properly with this modification (100% or 0% only using the OS sound volume control).

So this is a partial solution but this is better than nothing. I tried many solutions involving hdajackretask or alsa-base.conf, or what's described here with no luck. ALC294 seems to be a tough one for Linux :).

I added this configuration on https://doc.ubuntu-fr.org/audio_intel_hda.

7
  • Thanks for your help, model=asus-zenbook also worked for me, btw it allows me to determine sound level at any stage as well. Thank you again! – unaidx Sep 24 '20 at 8:42
  • 1
    Great :). Good for you if the sound volume control works fine, the all-or-nothing bug is quite annoying ! – Florian Motteau Sep 24 '20 at 9:07
  • My sound volume started to work today after an OS update :) – Florian Motteau Sep 25 '20 at 11:58
  • Nice :) happy to hear that, at last it will work as expected :) – unaidx Sep 30 '20 at 16:42
  • 2
    Can confirm, the accepted answer works on my G732LWS as well. On the volume control, system volume doesn't affect it at all for me either (0% or 100%). BUT you can control it via pavucontrol. – Vulcanite Oct 27 '20 at 9:40
1

For volume control after editing "options snd-hda-intel model=asus-zenbook"

try: My volume is either max volume or muted, no middle ground

1
  • You save my day – tenta4 Feb 24 at 15:31
0

Please try these commands in a terminal

sudo apt-get install --reinstall alsa-base pulseaudio

and then

sudo alsa force-reload

Restart and check if sound is back or not.

1
  • 1
    i just tried but unfortunately it does not worked, thank you anyway – unaidx Sep 20 '20 at 11:57
0

Additionally, after I saw the answer under this question I tried to use hdajackretask with this commands,

sudo apt install alsa-tools-gui
Run hdajackretask

I saw that default codec was NVIDIA GPU 93, so I tried to change it by following this path;

select a codec > Realtek ALC294 >apply now

error:

tee : /sys/class/sound/hwC0D0/reconfig : Device or resource is busy

I would like to share if it leads any idea..

0

I had the same problem with a Asus Rog Strix G712LV. When I installed Ubuntu Studio 20.4, the sound worked flawlessly. After a kernel upgrade, it stopped working.

options snd-hda-intel model=asus-zenbook

worked for me but I could not control the volume any more. The only solution I found was to stick to kernel 5.4.0-42. No more sound with recent kernels (5.4.0-59 and 5.4.0-60).

I know this is not a long term solution as it can lead to security issues.

Not the answer you're looking for? Browse other questions tagged or ask your own question.