13

Today I realized that Night Light stopped working in my machine. When I try to set it up, nothing happens. See attached gif:

trying to enable night light

I am not sure what's causing it to fail. I don't know if there are any logs generated by this tool, or if there's another way to enable Night Light.

Any idea what to try? This was working a few months ago.

When I check /var/log/syslog, there are some messages related to night light when I use the «Sunset to Sunrise» schedule, but nothing indicates that it failed:

Sep 19 22:46:37 sambayon gnome-control-c[22940]: no sunset data, using 16.00
Sep 19 22:46:37 sambayon gnome-control-c[22940]: no sunrise data, using 8.00
4
  • 1
    As a workaround, I have installed the sct program and using it manually, but it would be nice if I could fix Night Light.
    – Marco
    Sep 20 '20 at 5:53
  • I just realized that the night light wouldn't show up in a OBS recorded video. Regardless of that, there's no noticeable change in the display color temperature. What happens in the gif, is the same as what I'm seeing on the screen.
    – Marco
    Sep 20 '20 at 5:56
  • It happened to me too. I have it set to manual timing, from 05:00 to 04:59. When it broke, even the nightlight icon did not show up in the panel. But I noticed that my monitors (laptop + external HDMI) have disappeared from the Settings app's Color settings sidebar item. I set the preinstalled D50 color profile for my laptop's screen on that Color settings UI. But now only my printer had shown up to set a color profile to: the monitors did not. I think it's related. A reboot however restored everything: the Color settings UI, the laptop screen color profile, and night light.
    – Levente
    Feb 28 at 1:57
  • @Levente - you should post this as an answer as it seems to be a solution, and also so it can be voted upon. Feb 28 at 12:19
3

I encountered the same problem in 20.04, so I tried to reinstall gnome-control-center and then tried to restart my computer and it works.

Try running this command in a terminal to reinstall control center:

sudo apt-get install --reinstall gnome-control-center

and then restart you computer.

0

Flux was conflicting with the night light program, after enabling the Manual mode worked for me. enter image description here

0

For me, It worked by just rebooting my system.

-1

I encountered the same issue in Ubuntu 20.10. After turning on night light, I restart the computer and it works normally.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.