I want to install GNU Parallel in Ubuntu but I can't find a package for it in the default Ubuntu repos. Where can I get it?


11 Answers 11


In 13.04, you can install with apt-get:

sudo apt-get install parallel
sudo rm /etc/parallel/config

The second line is necessary because GNU parallel is installed in --tollef mode (if anyone can provide a rationale for this, I'd like to know).

In 14.04, the config file is apparently no longer included, since the --tollef option was removed from the GNU parallel source entirely: http://lists.gnu.org/archive/html/parallel/2013-02/msg00018.html

  • turn this into a wiki answer and let's pile up all the ways to install it (for 10.04, 10.10, 11.X, 13.04, etc) May 22, 2013 at 16:36
  • Probably available via this method as of Ubuntu 12.10 "Quantal": packages.ubuntu.com/quantal/parallel May 30, 2013 at 21:48
  • The rationale behind the setting in ` /etc/parallel/config` is perhaps that moreutils already include a version of Tollef's parallel. See also unix.stackexchange.com/questions/7515/using-parallel-on-ubuntu.
    – krlmlr
    Oct 8, 2013 at 12:32
  • All I needed for 20.04 was sudo apt install parallel and it just worked. No need for the 2nd line.
    – labyrinth
    Aug 5, 2020 at 21:28
  • Getting E: Unable to locate package parallel error message with Ubuntu 20.04 LTS.
    – Adrian
    Jun 27 at 11:33


This should work well with 10.10. If not, you could also try the Debian 5.0 Package from here.


Just to clarify: Even though this link is to the OpenSUSE build service, it is an Ubuntu package.

Packages for more recent Ubuntu versions are also available.


As of today (11th March 2015) I recommend reading:


Basically moreutils and gnu parallel can't get along.

You can do

sudo apt-get install parallel

but you will lose moreutils - even if you don't use moreutils parallel, you would lose for example ifne as well.

You could build from scratch as in the other answer.

I did

sudo apt-get install parallel
sudo mv /usr/bin/parallel /usr/bin/gnu_parallel
sudo apt-get install moreutils

And then used gnu_parallel in my scripts

  • 1
    This bug has been fixed in 17.04, finally. Sep 25, 2017 at 15:43
  • this might come up on 20.x too. If I run parallel on a clean ubuntu image it will claim it's not installed and suggest installing moreutils to get it, but it won't work as expected! time sink!
    – Pedro
    Mar 17 at 18:59

I'm on Ubuntu 11.10, and there still isn't a Canonical package of GNU Parallel. It's pretty easy to manually add though.

  1. Go to the official GNU Parallel site: http://www.gnu.org/software/parallel/
  2. Download the latest source tarball: http://ftp.gnu.org/gnu/parallel/
  3. Unpack and make it.


wget http://ftp.gnu.org/gnu/parallel/parallel-20120522.tar.bz2
tar -xvjf parallel*
cd parallel*
sudo make install

You can use the zeroinstall feed (it should work on any os / distro):

apt-get install zeroinstall-injector
0alias parallel http://git.savannah.gnu.org/cgit/parallel.git/plain/packager/0install/parallel.xml

then just run it using the parallel command.

See http://0install.net for more info about zero install.


I looked today (2011-01-25) and didn't find any ppa or other apt repository. I did find https://launchpad.net/parallel but it only links to external resources.

Also the parallel command in the moreutils package is NOT GNU parallel but http://kitenet.net/~joey/code/moreutils/ which is not as full featured.

It's in macports and many other distributions so it should be included in Ubuntu too.



Or include this in your source.list:

deb http://ppa.launchpad.net/ieltonf/ppa/ubuntu oneiric main 
deb-src http://ppa.launchpad.net/ieltonf/ppa/ubuntu oneiric main 

It's available in *buntu 13.10 and will be 14.04LTS.


It seems like it isn't packaged in Ubuntu & Debian, maybe you can request it be packaged.

There are also some other tools with similar features (parallel remote execution of commands on multiple systems) in the repositories that you might want to check out. (Maybe somebody else can recommend some of these.)

  • 1
    I requested it be packaged in pad.lv/740630
    – poolie
    Mar 23, 2011 at 0:51
  • JanC, the nice thing about gnu parallel is that it's happy to run the commands locally, rather than assuming parallelism is across different machines.
    – poolie
    Mar 23, 2011 at 0:52

For Ubuntu 12.04 you can download it from http://packages.ubuntu.com/precise-backports/all/parallel/download

and of course install with dpkg -i


You can install latest version using LinuxBrew:

brew install parallel

As of today, current Version installed is 20150922. You can check it's Formula.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.