I upgraded Ubuntu from 11.10 to 12.04, until which wireless was working just fine. After the upgrade and reboot, wireless is not even being detected (When I click the network manager icon in the top panel, it does not show the wireless networks. Neither the Enable wireless option is there). But my laptop's LED indicator shows wireless is on.

This is a Dell Vostro 3450 laptop with:

Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)** (from lspci). Is any other info needed?

How do I get Wifi working?


5 Answers 5


I have a vostro myself. But a BCM43224. Maybe the solution does not fit for you. However this helped me out. Somehow the "sta" driver stopped working correctly. You need to install another driver. Before installing remove the following packages

sudo apt-get purge bcmwl-kernel-source broadcom-sta-common broadcom-sta-source

(removing these was essential for me. Without I had massive connection problems with the b43 driver)

Afterwards install the following packages

sudo apt-get install b43-fwcutter firmware-b43-installer
sudo echo b43 >> /etc/modules

then reboot and check if your card is found. (You can try by hand without rebooting. If you currently use the wl driver execute

sudo modprobe -r wl
sudo modprobe b43


More info, what helped me can be found here:



Alternatively try the driver described here: http://www.linuxwireless.org/en/users/Drivers/brcm80211 this one should support your chip.

  • dude youre saved my day! Oct 7, 2012 at 20:45
  • Make sure that wireless switch is switched on, in my case I had a special button on the notebook keyboard. Oct 8, 2022 at 14:59

I had the same problem. I tried the "b43-fwcutter firmware-b43-installer" package solution given above. The wireless started working but its behaviour was very erratic. Wireless network wasn't turned on at startup and if I tried to turn on the interface without first manually turning on the device (ifconfig wlan0 up) the whole system used to freeze up.

Hence, I tried an alternate approach. I went into ubuntu's "additional driver" application. There I saw that the "Broadcom STA proprietary driver" was disabled. I unloaded the b43 module (Removed it from /etc/modules too). Connected to the net using a wired interface and enabled this driver. Its been running smoothly since. Hope this reply helps.


My WiFi problem (explained here) is solved by installing broadcom-sta-common (on 12.04.2 LTS), then restart (not purging the package, as written in the first answer):

sudo apt-get update
sudo apt-get -y install broadcom-sta-common
sudo reboot

My device is:

$ lspci | grep BCM

03:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)

My Lenovo S10-3 Ideapad netbook also uses Broadcom BCM4313 wireless chip. When I did a 12.04 clean install, it identified the chip correctly even without activating the Broadcom STA driver. So I think the upgrading you did broke something along the way.

Open up the Additional Drivers (jockey-gtk) and see if the Broadcom STA driver is activated. Click the Activate button if it is not, be sure that you have an wired Internet connection on your system.

  • I'm just installing 12.04 on an S10-3 right now - how's your performance on that little thing? It's only got a gig of ram and a 1.66GHz processor... Do you have any recommendations? Apr 14, 2014 at 1:53

Checking the links above, you need to check first which Broadcom firmware you are using. The drivers are very specific. In particular, noting the posts above, the BCM4313 chipset is NOT supported by the b43 drivers, and these require the STA driver.

(I have a Dell Studio with BCM4313 wireless, that's how I know...).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .