1

I have installed 20.04 on a Dell OptiPlex 7050, with an Intel HD Graphics 630 (rev 04).

The boot process hangs on the splash screen. This does not happen on the first reboot immediately after installation, but on the next boot after that.

I have some partial solutions by adjusting the line GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub:

  1. Use 'nomodeset' in addition to the default 'quiet splash'. The system boots with the splash screen, but this option seems to disable some graphics functionality permanently (not just during the boot): after booting with 'nomodeset', all compositor animations in gnome-shell are disabled.

  2. Replace 'quiet splash' with 'nosplash'. This works better: the system is both able to boot, and composting animations work. The only downside is that you don't have a splash screen.

Question: It should be possible to have both a splash screen during boot, and working gnome-shell animations. How can this be achieved?

(Personally, I don't really care about the splash screen, but this problem cost me enough time and headache that I wanted to post something for others.)

0

You should try this:

  1. Log in to recovery mode and then 'resume'
  2. Edit /etc/default/grub, change the line GRUB_CMDLINE_LINUX_DEFAULT so that: "quiet splash" becomes "dis_ucode_ldr quiet splash"
  3. Run: sudo update-grub

Hopefully, this works for you.

New contributor
Akkien is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
1
  • You should really say what this does as it is rarely a good idea to use this parameter permanently. This parameter disables microcode (firmware) updates which normally happen on every boot. While microcode updates can very occasionally cause boot problems, they are important for security. See wiki.debian.org/Microcode. If someone tries this and finds it does not work, they should revert it. If it does work, they should try to revert it periodically to see if the bug got fixed. – Zanna 2 days ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.