I'm Ubuntu and linux newbie.


Ubuntu 12.04 have driver for this printer, but this driver don't have all option. Just for printing, no ink level, etc.

No driver for scanner! Scanner doesn't work at all.

I try this driver http://www.epson.co.uk/Printers-and-All-In-Ones/Inkjet/Epson-Stylus-DX4450/Drivers-Support and follow install instruction, but nothing change.

Change operating system to windows or mac to see how much drivers are there.

So, does anyone know where/how to install this scanner/printer?

2 Answers 2


Well, I've got the same type of all-in-one, but I don't use the printer part because it has got problem – so I haven't even tried to print with it, so this part of the question I can't answer. (TwoD has successfully used the printer part.)

HOWEVER, I've had the same problem with the scanner part... I've searched for a solution but none of them worked. Until today, when I've found an extensive guide – but it works! (And then I've started to look for unanswered questions like this... now here I am).

So, what you should do are the following.

Go: http://www.avasys.jp/lx-bin2/linux_e/spc/DL1.do

Scroll down until you reach "Form for download" part. Here choose "Epson Stylus CX4300/CX4400/CX4450/CX5500/CX5600/DX4400/DX4450" (it's the first column second row).

Scroll down to "Questionnare". Select the proper distribution and version (when writing this answer, 12.04 isn't present, choose 11.10).

On the next page scroll down until "Scanner driver". Download the followings:

First, the "deb package", (at the moment it's iscan-data_1.13.0-1_all.deb but version number may change by the time you visit). Then scroll a bit down, and at "blahblahblah core package" download the two files listed under "deb 32bit package [libltdl7] (for Ubuntu 8.10 or later)" or "deb 64bit package [libltdl7] (for Ubuntu 8.10 or later)", depending on that you use either a 32-bit or a 64-bit system. (If you don't know what I'm talking about, just download the 32-bit version.) For example, if 32-bit version, the two file names at the moment (they may change) are: iscan_2.28.1-3.ltdl7_i386.deb and iscan-plugin-cx4400_2.1.3-1_i386.deb

Now you've got 3 files. Now you need to install them. In fact, I don't use Ubuntu but Lubuntu, what's more, not in English, so I don't exactly know how is the program called on your system with which you can install them. It must be a "package installer" or such. (The proper program may be assigned to the file format, but if not (e.g. if "Archive manager" or such is assigned), then you will find the proper one under Administration menu.)

You can also do this from a terminal: Change the working directory to where you downloaded the files with

cd ~/Download

Install all the iscan packages at once with

sudo dpkg -i iscan*.deb

After you've installed these packages, we may need to get a level deeper in system settings.

First see if your scanner has already been detected by going to "Graphics" -> "Image scan! for Linux" or "XSane Image scanning program" on the Applications menu. It will attempt to find the scanner. If it fails, unplug it and plug it back in, then try reopening the program.

If the scanner is still not detected, you may have to manually alter some files to tell the system which driver to use and how to classify the device when it is detected. The packages should have taken care of all this earlier, but it may have failed.

Open a terminal.


gksu gedit /etc/sane.d/epkowa.conf

(and then type your password – in the following it will often require your password.) A textfile will appear. Find the line which contains only the word "scsi". Optionally put a # sign in front of "scsi" if you only use USB scanners. Then find the line containing only the word "#usb". Delete the # sign if it's there. Close the file (and save it, of course.) This tells the epkowa backend which bus(es) it needs to check for scanners.


gksu gedit /etc/sane.d/dll.conf

Find in the list the line containing "epson". Put a # in front of it. Save and close the file. This disables the Epson backend for iscan.


gksu gedit /etc/sane.d/dll.d/iscan

Make sure the file which was just opened has a line with the single word "epkowa" in it. Add it if neeeded, then save and close the file. This enables the epkowa backend for iscan.


gksu gedit /etc/udev/rules.d/45-libsane.rules

You may get an empty file (if not, start a new line). Insert the following text (with all characters):

# Epson Stylus CX-4300 CX-4400 CX-4450 CX-5500 CX-5600 DX-4400 DX-4450
SYSFS{idVendor}=="04b8", SYSFS{idProduct}=="083f", MODE="664", GROUP="scanner"

Now you MAY need to reboot the system. Unplugging and plugging the device back in should be enough in most cases.

After that, turn on the all-in-one machine.

Open a terminal, and type:


You will get a long text, but there will be a line among them, similar to this:

found USB scanner (vendor=0x04b8 [Language Error], product=0x083f [Language Error]) at libusb:004:002

You will need the last two numbers, in my case 004 and 002, but you will certainly get different ones.

If you see more than one line, try unplugging other devices which may have scanning capabilities, such as some phones or cameras, and run the command again.

Your user may need to be added to the "scanner" group to have access, or you could [temporarily?] give everyone access to the scanner.

To do that, type the following into the terminal, but replace my 004 and 002 numbers with your ones:

sudo chmod 0755 /proc/bus/usb/004/002

(Password will be necessary again.) It's possible that you get an error message. Check if you've spelled everything correctly, and if you did, ignore that error message and try adding your user to the "scanner" group instead.

And now, WE ARE READY!

In your Applications menu, under Graphics, you'll find "Image scan! for Linux" or "XSane Image scanning program". Start it, and you'll get an interface similar to Epson Scan in Windows.

I hope everything worked. If not, please tell me and I might be able to answer.


On my Ubuntu 12.04 system, my scanner's drive (DX4400) failed to function when the scanner was attached through a 4-way USB hub. When I removed the HUB and connected the scanner directly to my computer, the problem was fixed. This should work on both 64-bit and 32-bit versions of Ubuntu.

Not the answer you're looking for? Browse other questions tagged or ask your own question.