1

Ubuntu Studio stopped detecting my monitor's EDID data, and has defaulted to 1024x768. The display can do 1920x1080 and was previously being detected and set correctly. The monitor is still detected correctly by Kubuntu 20.04 and, tellingly, by an Ubuntu Studio 20.04 live DVD and other OS instances on the same machine. This suggests to me that the problem is not in the hardware. Running xrandr by itself produces the following output: "xrandr: Failed to get size of gamma for output default Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768 default connected 1024x768+0+0 0mm x 0mm 1024x768 76.00*" I've tried using various methods to set the display mode, but the problem persists. I've also tried reinstalling the video card drivers and xrandr itself, and creating a xorg.conf file with the correct modeline, all to no avail. I suspect some file or library has been corrupted or removed, but have no idea what to look for.

1

[Solved] It turns out my suspicion may have been correct - I discovered the system was missing the file edid-decode, and after I installed it, the monitor was detected correctly again.

1
  • It now appears that adding edid-decode was either a temporary fix or irrelevant - the problem has returned after a recent update, inxi -G produces: "Graphics: Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] driver: N/A Display: x11 server: X.Org 1.20.8 driver: fbdev,nouveau unloaded: modesetting,vesa resolution: 1024x768~76Hz OpenGL: renderer: llvmpipe (LLVM 10.0.0 128 bits) v: 3.3 Mesa 20.0.8.", though I have the latest nvidia driver for my card installed.
    – Al Preston
    Sep 30 '20 at 5:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.