I have changed my default cursor theme to the DMZ black, but when my mouse hovers over any Skype window, it turns into DMZ white (only while hovering). When I try to take a screenshot of it, the cursor shows up as black on the image, which is rather weird.

Anybody who's got an idea how to fix it?

  • I am quite sure that skype uses QT for window rendering, because of this you might have to change som qt/kde setting. But how I have no idea. – LassePoulsen Nov 12 '10 at 0:54
  • yuck! I already disliked skype in ubuntu, now I absolutely hate it :| – theTuxRacer Dec 3 '10 at 13:53
  • This doesn't happen for me. What versions are you using (skype and ubuntu)? – David Oneill Dec 17 '10 at 17:18

This is common problem with Skype, I've had it too. To fix it, you need to install kde's system-settings (sadly, no option for the cursor in qt-config, and it's probably not so trivial, or wise to edit the qt-config by hand). In KDE's system settings, choose the mouse option to change your Qt cursor theme.

Another possible fix is to change the default theme for your entire system. Run galternatives and change the x-cursor theme to the one you currently use.

| improve this answer | |
  • The galternatives did the trick, and if I'm lucky, it'll fix another annoyance I've had: that the cursor changes briefly during login, even though I've changed the gdm-cursor theme to DMZ-black. Thanks a lot! – LasseValentini Dec 17 '10 at 17:38
  • galternatives did the trick – logcat Sep 26 '13 at 14:11

Strange, but on my system (13.04) the issue has been healed just through installation of libxcursor1:i386.

| improve this answer | |
  • worked for me as well – Rain Aug 15 '13 at 10:12
  • worked for me too, the simplest solution so far! – Dmitry Pashkevich Mar 2 '14 at 19:59

I'm using th Mint KDE 16 64 bit, and I install skype from software center, and have that problem. Then I run install command on terminal shell:

sudo apt-get install libxcursor1:i386

After that I reboot the computer, and it's done.

| improve this answer | |
  • no need to reboot, just restart skype – user1446688 Jun 25 '14 at 0:18

Maybe someone else would be also interested in another possible solution: when I installed Skype from Ubuntu repository (11.10) I also had the same issue - but I've tried downloading and installing Skype client from skype.com page and then after installing it - normal KDE settings applies on it as well...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.