3

I have connected a Sennheiser headset HD 4.40 Bluetooth to Ubuntu 20.04 but its microphone is not working. I can see it on the audio configuration window but the test bar does not move at all, it does not detect any audio. The headphones are working OK.

I am using a Plugable USB 2.0 Bluetooth adapter:

Bus 001 Device 002: ID 0a5c:21e8 Broadcom Corp. BCM20702A0 Bluetooth 4.0

Any ideas about how to fix this?

  • Which audio profile are you using A2DP or HSP? A2DP doesn't support microphone, HSP quality is crap. – muru Sep 17 at 9:10
  • I have tried with both profiles, none of them work. – Óscar Sep 17 at 13:57
1

I have fixed this by unpairing ("Remove device") the headset and pairing it again. Initially Ubuntu microphone test bar did not move at all, but I tried in an application and the mic worked, and when going back to Ubuntu sound window the mic bar was detecting sound.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.