2

I use ubuntu 20.04 on a Dell Inspiron 7567 laptop. I have this reoccurring issue where the laptop completely freezes. This happens every 5 - 6 hours. The mouse becomes unresponsive, and all the processes in the background stop and if music is playing in the background, then the sound turns into some sort of grating beep. I can no longer suspend as usual by pressing the power button. The keyboard inputs also don't work.

The only way to recover is with a hard restart by holding the power button.

This never happens when I use windows so I am sure that it is not a hardware issue. I don't think it is related to the Nvidia drivers as even when I use the intel card with the sudo prime-select intel command, the problem still occurs.

I cannot get any information out of /var/logs/syslogs. I have been having this issue for months and just cannot seem to solve it.

Can anyone please help.

3
  • Look up how to run MEMTEST on your RAM.
    – user535733
    Sep 17, 2020 at 5:48
  • I did and it showed that there was nothing wrong.
    – Srijan
    Sep 17, 2020 at 16:16
  • Edit your question and show me free -h and sysctl vm.swappiness and grep -i swap /etc/fstab and sudo lshw -C memory and ls -al /var/crash. Start comments to me with @heynnema or I'll miss them.
    – heynnema
    Feb 18, 2021 at 20:46

2 Answers 2

1

Probably the driver thing. The next time that occurs you can connect and login to your laptop using mobile phone or other device via ssh service on Ubuntu, and try to find out what has happened according to dmesg logs.

1
  • Hi, I tried that. The ssh on my machine seems to close as well and I cannot ssh into the device as I usually do when the laptop freezes.
    – Srijan
    Sep 18, 2020 at 0:01
0

This is a bug in recent updates to the Linux Kernel for 20.04 and most other recent Debian distros for some recent Intel CPUs. The CPU is spontaneously going to sleep. There are workarounds that attempt to disable CPU sleeping by not loading that kernel module with a grub boot option, but it didn't help for me. The recommended fix on Framework laptops is to upgrade the Bios. But my bios installer for Windows is in Beta and the problem only got worse. I have less than 10 seconds now before the CPU sleeps and everything freezes. I've tried dozens of things, even booting recent Kali from USB. No joy. Only option seems to be to downgrade the kernel. So I've created a bootable USB with Ubuntu 18 (using another laptop that has an AMD CPU). Will post again if the problem recurs on older kernel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.