I just upgraded from Ubuntu 11.10 to 12.04 on an HP Mini netbook, and I have quite an annoying problem: there is no mouse cursor. On the login screen, I can see the cursor, but I cannot move it (neither with the USB mouse, nor with the touchpad). After I login, the cursor disappears.

I also installed on a virtual machine, on a different computer, and there everything works fine.

Does anyone else experience this?

Or do you know how I could fix this?

  • I have been extensively testing my HP Mini (210-2053TU) with fresh installs of both 12.04 beta2 and 12.04 release. Not experiencing your issue .. – david6 Apr 29 '12 at 8:00
  • Yes, I am experiencing this issuea as well. I am on Lenevo U260 Ideapad. – Senthil Kumaran Apr 29 '12 at 8:52
  • same problem toshiba satellite laptop – Joshua Robison Apr 30 '12 at 23:55

I attached to a wired connection and reboot and tried installing the drivers which were available, Rebooted and it magically solved the problem.

  • Attach to a wired connection? Good point! I haven't noticed that my wireless is disabled. The problem is, when I plug in a cable I get a "System error" message - yes, that's all, no further description. – cosmin Apr 29 '12 at 18:08
  • 1
    Attach to Wired and reboot. Later Press F10, and to go System Update and try to install all updates. You could also try installing restricted extras. I did all these and found it working. – Senthil Kumaran Apr 30 '12 at 1:53

Are you talking about the mouse or the touchpad of the laptop ?
Because for the touchpad, it happens some time when upgrading.

For the touchpad, plug in a mouse and :


  • When upgrading to Oneiric, it happens to me and I solved it using a simple command found in AskUbuntu. I think I used $ synclient TouchpadOff=0
    See in this answer
  • For me, neither the touchpad nor the mouse work. – cosmin Apr 29 '12 at 18:06
  • neither touchpad nor mouse work for me either – Joshua Robison Apr 30 '12 at 23:56

Had the same/similar issue and resolved it.

So yesterday I upgraded to Ubuntu 12.04. Everything seemed to go on fine...however, when the system rebooted, both keyboard and mouse did not work at the login screen. Tried different things (rebooting system without connecting keyboard/mouse, connecting it later on etc...but nothing worked).

In the end, pressed the "Shift" key when the system reboots to bring up the menu (that has options to boot into recovery mode, prior linux versions etc)..and..

Booting into recovery mode did not help. Booted into a prior linux version. Login screen was displayed, and mouse/keyboard worked. Thus, i could login to the system. I noticed that there was a notification that there were certain unmet dependencies. Opened up a terminal and typed in the following command:

 sudo apt-get -f install

This installed a bunch of things. Rebooted the system once the above command executed successfully. This time I could login successfully as the keyboard/mouse was working. On login, there was an error (do not remember what it was). I opened up a terminal window and executed the following command

  sudo apt-get -f upgrade

Took a few minutes. Rebooted the system once the above command executed successfully.

System is operational again. No errors.

Hope this helps someone. Thanks!

  • for some reason the drivers for my wired connection neglected to install as well. I think this is an issue maybe for people who do the install without being connected to a wired connection. I did the install while connected wirelessly. – Joshua Robison May 1 '12 at 0:07

Worked for me after a clean install.

The thing is, I had this problem after an update from 11.10. Then I tried to install from the CD image, but without formatting the root partition - still no mouse. I could only fix it by choosing to format the partition on reinstall. I also used the wired connection this time - just to be sure.

I wish I knew the cause, though... I have another computer running 11.10, and now I'm afraid to upgrade :D


[Solved] Well finally figured out the cause for the delay(30 seconds) in detecting the keyboard and mouse in mine.

I'm using a iBall web cam connected to a USB 3.0 Port which was causing the delay in detecting the Input devices..By just unplugging the web cam from the USB 3.0 port and plugging it to a USB 2.0 port, the mouse and keyboard started working fine during the login screen..

Just give a try swapping your USB devices to other ports and try if that fixes the problem, Thanks


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.