I've recently installed Kubuntu 20.04 on an old Thinkpad Helix. It's been mostly working fine, except sometimes the touchpad and trackpoint stop working. Sometimes it happens when the tablet is undocked/redocked, sometimes it happens after resuming from sleep, and sometimes it just happens randomly.

The built in stylus (wacom tablet) and the touchscreen work fine.

The keyboard and USB ports on the keyboard work fine.

So far, the only fix I've found is rebooting the device, which is annoying to do.

I found an answer which said to install xserver-xorg-input-synaptics and run synclient TouchpadOff=0 but it didn't work.

3 Answers 3


As pointed out here ,the following commands restore touchpad and trackpoint functionality:

sudo rmmod psmouse -f -v

and then

sudo modprobe psmouse -v

(I usually have to execute the commands several times, before functionality comes back)

  • Thanks, I'll try it next time it stops working. Nov 13, 2020 at 3:00
  • It works! Thanks for your help. :) Nov 15, 2020 at 12:47

My wife and I have Lenovo A475 laptops. We both use Ubuntu (she 20.04, me 21.04) and recently our trackpads and trackpoints both stopped working, hers a few weeks before mine. For me it happened on undocking. Restarting the computer would not fix the issue. Restarting in another Linux distro did not have them working either. I was about to buy new trackpads on eBay, because it sure looked like a hardware issue. The thing that made me pause is the trackpoint and touchpad are different hardware, and they both quit simultaneously on both computers. So as one more test, I downloaded a Windows 10 .iso and made an install USB drive using WoeUSB. When I plugged it in and booted on that USB drive (without installing Windows), I found the trackpad and trackpoint both worked. Rebooting into Linux showed everything worked there too. I would have thought this was flakey hardware coming back to life, but booting my wife's machine on the same USB stick repaired her problem too the same way. I suspect the Windows USB stick re-initialized the trackpad and trackpoint somehow.

  • Recently my daughter's Lenovo Yoga 260 had the same thing where her trackpad stopped working. We replaced it with another, but it was the same. It appears the same thing that cured our A475 units also worked for her Yoga 260.
    – Rob Frohne
    Dec 8, 2021 at 4:35

I don't know if this is still relevant to you but I've managed to solve it by adding psmouse.synaptics.intertouch=0 to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub like this:

# /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="<...your stuff> psmouse.synaptics.intertouch=0"

Now touchpad and trackpoint are no longer stop working. Tried on Xubuntu 22.04 and Void Linux with good results.

  • Thanks for your answer, I'll try it out but it doesn't really happen that frequently anymore so It'll be hard for me to test if it works Dec 20, 2022 at 11:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.