6

I was following this guide to set up SSH authentication with keys, but after following all the steps if I try to login the server still asks for my password.

So I went to check /etc/ssh/sshd_config as the guide recommends, and these two:

PubkeyAuthentication yes
RSAAuthentication yes

Were commented out, so I enabled them.

Unfortunately the login still didn't work and when checking sudo tail -f /var/log/auth.log I just got:

rexec line 38: Deprecated option RSAAuthentication

Is there an up-to-date guide on how to login via SSH with a key?

These are my sshd_config settings https://pastebin.com/Y4W9Vmtk

Version:

 lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.1 LTS
Release:        18.04
Codename:       bionic

Current Open ssh version

ssh -V
OpenSSH_7.6p1 Ubuntu-4ubuntu0.3, OpenSSL 1.0.2n  7 Dec 2017

ssh -vvvv [email protected] output

OpenSSH_8.2p1 Ubuntu-4, OpenSSL 1.1.1f  31 Mar 2020
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: include /etc/ssh/ssh_config.d/*.conf matched no files
debug1: /etc/ssh/ssh_config line 21: Applying options for *
debug2: resolving "mysite.com" port 22
debug2: ssh_connect_direct
debug1: Connecting to mysite.com [ip address] port 22.
debug1: Connection established.
debug1: identity file /home/user/.ssh/id_rsa type 0
debug1: identity file /home/user/.ssh/id_rsa-cert type -1
debug1: identity file /home/user/.ssh/id_dsa type -1
debug1: identity file /home/user/.ssh/id_dsa-cert type -1
debug1: identity file /home/user/.ssh/id_ecdsa type -1
debug1: identity file /home/user/.ssh/id_ecdsa-cert type -1
debug1: identity file /home/user/.ssh/id_ecdsa_sk type -1
debug1: identity file /home/user/.ssh/id_ecdsa_sk-cert type -1
debug1: identity file /home/user/.ssh/id_ed25519 type -1
debug1: identity file /home/user/.ssh/id_ed25519-cert type -1
debug1: identity file /home/user/.ssh/id_ed25519_sk type -1
debug1: identity file /home/user/.ssh/id_ed25519_sk-cert type -1
debug1: identity file /home/user/.ssh/id_xmss type -1
debug1: identity file /home/user/.ssh/id_xmss-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_8.2p1 Ubuntu-4
debug1: Remote protocol version 2.0, remote software version OpenSSH_7.6p1 Ubuntu-4ubuntu0.3
debug1: match: OpenSSH_7.6p1 Ubuntu-4ubuntu0.3 pat OpenSSH_7.0*,OpenSSH_7.1*,OpenSSH_7.2*,OpenSSH_7.3*,OpenSSH_7.4*,OpenSSH_7.5*,OpenSSH_7.6*,OpenSSH_7.7* compat 0x04000002
debug2: fd 3 setting O_NONBLOCK
debug1: Authenticating to mysite.com:22 as 'user'
debug3: hostkeys_foreach: reading file "/home/user/.ssh/known_hosts"
debug3: record_hostkey: found key type ECDSA in file /home/user/.ssh/known_hosts:5
debug3: load_hostkeys: loaded 1 keys from mysite.com
debug3: order_hostkeyalgs: prefer hostkeyalgs: [email protected],[email protected],[email protected],ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521
debug3: send packet: type 20
debug1: SSH2_MSG_KEXINIT sent
debug3: receive packet: type 20
debug1: SSH2_MSG_KEXINIT received
debug2: local client KEXINIT proposal
debug2: KEX algorithms: curve25519-sha256,[email protected],ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group16-sha512,diffie-hellman-group18-sha512,diffie-hellman-group14-sha256,ext-info-c
debug2: host key algorithms: [email protected],[email protected],[email protected],ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,[email protected],[email protected],[email protected],[email protected],[email protected],[email protected],[email protected],ssh-ed25519,[email protected],rsa-sha2-512,rsa-sha2-256,ssh-rsa
debug2: ciphers ctos: [email protected],aes128-ctr,aes192-ctr,aes256-ctr,[email protected],[email protected]
debug2: ciphers stoc: [email protected],aes128-ctr,aes192-ctr,aes256-ctr,[email protected],[email protected]
debug2: MACs ctos: [email protected],[email protected],[email protected],[email protected],[email protected],[email protected],[email protected],hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: MACs stoc: [email protected],[email protected],[email protected],[email protected],[email protected],[email protected],[email protected],hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: compression ctos: none,[email protected],zlib
debug2: compression stoc: none,[email protected],zlib
debug2: languages ctos:
debug2: languages stoc:
debug2: first_kex_follows 0
debug2: reserved 0
debug2: peer server KEXINIT proposal
debug2: KEX algorithms: curve25519-sha256,[email protected],ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group16-sha512,diffie-hellman-group18-sha512,diffie-hellman-group14-sha256,diffie-hellman-group14-sha1
debug2: host key algorithms: ssh-rsa,rsa-sha2-512,rsa-sha2-256,ecdsa-sha2-nistp256,ssh-ed25519
debug2: ciphers ctos: [email protected],aes128-ctr,aes192-ctr,aes256-ctr,[email protected],[email protected]
debug2: ciphers stoc: [email protected],aes128-ctr,aes192-ctr,aes256-ctr,[email protected],[email protected]
debug2: MACs ctos: [email protected],[email protected],[email protected],[email protected],[email protected],[email protected],[email protected],hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: MACs stoc: [email protected],[email protected],[email protected],[email protected],[email protected],[email protected],[email protected],hmac-sha2-256,hmac-sha2-512,hmac-sha1
debug2: compression ctos: none,[email protected]
debug2: compression stoc: none,[email protected]
debug2: languages ctos:
debug2: languages stoc:
debug2: first_kex_follows 0
debug2: reserved 0
debug1: kex: algorithm: curve25519-sha256
debug1: kex: host key algorithm: ecdsa-sha2-nistp256
debug1: kex: server->client cipher: [email protected] MAC: <implicit> compression: none
debug1: kex: client->server cipher: [email protected] MAC: <implicit> compression: none
debug3: send packet: type 30
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug3: receive packet: type 31
debug1: Server host key: ecdsa-sha2-nistp256 SHA256:[redacted]
debug3: hostkeys_foreach: reading file "/home/user/.ssh/known_hosts"
debug3: record_hostkey: found key type ECDSA in file /home/user/.ssh/known_hosts:5
debug3: load_hostkeys: loaded 1 keys from mysite.com
debug3: hostkeys_foreach: reading file "/home/user/.ssh/known_hosts"
debug3: record_hostkey: found key type ECDSA in file /home/user/.ssh/known_hosts:6
debug3: load_hostkeys: loaded 1 keys from ip address
debug1: Host 'mysite.com' is known and matches the ECDSA host key.
debug1: Found key in /home/user/.ssh/known_hosts:5
debug3: send packet: type 21
debug2: set_newkeys: mode 1
debug1: rekey out after 134217728 blocks
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug3: receive packet: type 21
debug1: SSH2_MSG_NEWKEYS received
debug2: set_newkeys: mode 0
debug1: rekey in after 134217728 blocks
debug1: Will attempt key: /home/user/.ssh/id_rsa RSA SHA256:[redacted]
debug1: Will attempt key: /home/user/.ssh/id_dsa
debug1: Will attempt key: /home/user/.ssh/id_ecdsa
debug1: Will attempt key: /home/user/.ssh/id_ecdsa_sk
debug1: Will attempt key: /home/user/.ssh/id_ed25519
debug1: Will attempt key: /home/user/.ssh/id_ed25519_sk
debug1: Will attempt key: /home/user/.ssh/id_xmss
debug2: pubkey_prepare: done
debug3: send packet: type 5
debug3: receive packet: type 7
debug1: SSH2_MSG_EXT_INFO received
debug1: kex_input_ext_info: server-sig-algs=<ssh-ed25519,ssh-rsa,rsa-sha2-256,rsa-sha2-512,ssh-dss,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521>
debug3: receive packet: type 6
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug3: send packet: type 50
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey,password
debug3: start over, passed a different list publickey,password
debug3: preferred gssapi-with-mic,publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Offering public key: /home/user/.ssh/id_rsa RSA SHA256:[redacted]
debug3: send packet: type 50
debug2: we sent a publickey packet, wait for reply
debug3: receive packet: type 51
debug1: Authentications that can continue: publickey,password
debug1: Trying private key: /home/user/.ssh/id_dsa
debug3: no such identity: /home/user/.ssh/id_dsa: No such file or directory
debug1: Trying private key: /home/user/.ssh/id_ecdsa
debug3: no such identity: /home/user/.ssh/id_ecdsa: No such file or directory
debug1: Trying private key: /home/user/.ssh/id_ecdsa_sk
debug3: no such identity: /home/user/.ssh/id_ecdsa_sk: No such file or directory
debug1: Trying private key: /home/user/.ssh/id_ed25519
debug3: no such identity: /home/user/.ssh/id_ed25519: No such file or directory
debug1: Trying private key: /home/user/.ssh/id_ed25519_sk
debug3: no such identity: /home/user/.ssh/id_ed25519_sk: No such file or directory
debug1: Trying private key: /home/user/.ssh/id_xmss
debug3: no such identity: /home/user/.ssh/id_xmss: No such file or directory
debug2: we did not send a packet, disable method
debug3: authmethod_lookup password
debug3: remaining preferred: ,password
debug3: authmethod_is_enabled password
debug1: Next authentication method: password
14
  • 1
    The commented out options in the sshd_config are the defaults. So, if it says #RSAAuthentication yes. That means by default it is set to yes. You don't need to uncomment it. If you comment it back as before, can you login without entering the user password? My sshd_config only has #PubkeyAuthentication yes and no mention of RSAAuthentication. It works as expected.
    – user68186
    Sep 15, 2020 at 20:54
  • 2
    Remember to restart the sshd after each change in the sshd_config. Use a command like sudo service ssh restart.
    – user68186
    Sep 15, 2020 at 22:10
  • 1
    It looks like the public key may not be in the file /home/$USER/.ssh/authorized_keys in the remote server. Please check the content of this file in the remote computer. It should have a very very long line that starts with ssh-rsa and ends with username_iused_n_local_computer@local_computer_name . If this file does not exist or does not have the correct line, log out of the remote computer and use the following command in the local computer: ssh-copy-id [email protected]. This will copy the public key from the local computer to the remote computer in that file.
    – user68186
    Sep 17, 2020 at 14:42
  • 1
    Now that we know the file and the line exists, let's check the folder permission for ~/.ssh as well as the file permissions inside it. First, s -l -d ./.ssh should result in drwx------ for the folder in both the local and the remote computers. Second, in the local computer ls -l ./.ssh/ should show -rw------- for the id_rsa file. Third, in the remote computer you should get the same permissions -rw------- for authorized_keys file. If the permissions are different, use chmod 700 ~/.ssh and chmod 600 ~/.ssh/authorized_keys to fix permissions.
    – user68186
    Sep 17, 2020 at 16:30
  • 1
    If there are no entries other than those with leonardo@DESKTOP-GFS48E6 in the end, then delete the file authorized_keys in the remote computer. Then use this command ssh-copy-id [email protected] in the local computer. This will make the authorized_keys in the remote computer again.
    – user68186
    Sep 17, 2020 at 19:15

2 Answers 2

4

This has to do with RSA deprecation due to it becoming hackable by hardware that can be purchased under $50,000 USD...

The fix, for me, was.. on the client side, make sure you have a key that the server accepts, like ~/.ssh/id_ecdsa.pub .. if you only see id_rsa.pub, do this on the client side:

ssh-keygen -t ecdsa

..and then:

ssh-copy-id [email protected]

Enter the password for your user to copy the new ecdsa id to the server.. Now this should work without password:

ssh [email protected]

If that doesn't work, some troubleshooting tips:

Client:

ssh-keygen --help

usage: ssh-keygen [-q] [-b bits] [-t dsa | ecdsa | ed25519 | rsa | rsa1]
...

..above shows what types of keys (dsa, ecdsa, ed25519) your client can generate.

Server:

Check /etc/ssh/sshd_config for "HostKey" lines:

#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_ecdsa_key
#HostKey /etc/ssh/ssh_host_ed25519_key

..even though they're commented, the sshd_config default is to show defaults in comments. Mine clearly shows rsa as a default, but once rsa has been deprecated, it might not work even with the host key enabled..

Client:

ssh -vvvvv [email protected]

(look at the output, and determine what types of encryption keys are being used / what is failing)

More info can be learned from this excellent writeup:

https://levelup.gitconnected.com/demystifying-ssh-rsa-in-openssh-deprecation-notice-22feb1b52acd

0

Try the below guide if the following does not work, you need set no to using a password to only use a pubKEY which is:

nano /etc/ssh/sshd_config

Find the following lines and change the value to “no”:

PasswordAuthentication no
ChallengeResponseAuthentication no
UsePAM no

Save and close the file, then restart SSH service to apply the configuration:

systemctl restart ssh

The idea is you set password to no while setting yes to keys therfore SSH will always use keys and never ask for a password, it cannot do both at the same time and if both are set then it will always ask for the password and ignore keys.

Guide to try if above does not work: https://www.atlantic.net/vps-hosting/how-to-set-up-ssh-keys-on-ubuntu-18-04/

2
  • Doesn't setting PasswordAuthentication no essentially lock me out if this doesn't work and I lose connection? Sep 15, 2020 at 20:23
  • If you have both set to no for the pubkey options and password then yes, please see guide listed for full steps for Ubuntu 18.04 use ssh keys for login Sep 15, 2020 at 20:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .