2

I have Ubuntu 18.04 on Dell Vostro 15 - 3546.

uname -api

Linux vaishnavi-laptop 4.15.0-117-generic #118-Ubuntu SMP Fri Sep 4 20:02:41 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

I followed this post to install fusuma. Then when I run sudo fusuma:

I, [2020-09-15T09:45:33.978824 #15466]  INFO -- : reload config: /home/vaishnavi/.config/fusuma/config.yml
I, [2020-09-15T09:45:34.051674 #15466]  INFO -- : ---------------------------------------------
I, [2020-09-15T09:45:34.051794 #15466]  INFO -- : Fusuma: 1.11.1
I, [2020-09-15T09:45:34.061094 #15466]  INFO -- : libinput: 1.10.4
I, [2020-09-15T09:45:34.143106 #15466]  INFO -- : OS: Linux 4.15.0-117-generic #118-Ubuntu SMP Fri Sep 4 20:02:41 UTC 2020
I, [2020-09-15T09:45:34.145421 #15466]  INFO -- : Distribution: Ubuntu 18.04.4 LTS \n \l
I, [2020-09-15T09:45:34.147262 #15466]  INFO -- : Desktop session:
I, [2020-09-15T09:45:34.147340 #15466]  INFO -- : ---------------------------------------------
I, [2020-09-15T09:45:34.147393 #15466]  INFO -- : Enabled Plugins: 
I, [2020-09-15T09:45:34.147612 #15466]  INFO -- :   Fusuma::Plugin::Buffers::GestureBuffer
I, [2020-09-15T09:45:34.147659 #15466]  INFO -- :   Fusuma::Plugin::Detectors::PinchDetector
I, [2020-09-15T09:45:34.147692 #15466]  INFO -- :   Fusuma::Plugin::Detectors::RotateDetector
I, [2020-09-15T09:45:34.147729 #15466]  INFO -- :   Fusuma::Plugin::Detectors::SwipeDetector
I, [2020-09-15T09:45:34.147764 #15466]  INFO -- :   Fusuma::Plugin::Events::Records::GestureRecord
I, [2020-09-15T09:45:34.147804 #15466]  INFO -- :   Fusuma::Plugin::Events::Records::IndexRecord
I, [2020-09-15T09:45:34.147948 #15466]  INFO -- :   Fusuma::Plugin::Events::Records::TextRecord
I, [2020-09-15T09:45:34.147979 #15466]  INFO -- :   Fusuma::Plugin::Executors::CommandExecutor
I, [2020-09-15T09:45:34.148008 #15466]  INFO -- :   Fusuma::Plugin::Filters::LibinputDeviceFilter
I, [2020-09-15T09:45:34.148039 #15466]  INFO -- :   Fusuma::Plugin::Filters::LibinputTimeoutFilter
I, [2020-09-15T09:45:34.148081 #15466]  INFO -- :   Fusuma::Plugin::Inputs::LibinputCommandInput
I, [2020-09-15T09:45:34.148119 #15466]  INFO -- :   Fusuma::Plugin::Parsers::LibinputGestureParser
I, [2020-09-15T09:45:34.148177 #15466]  INFO -- : ---------------------------------------------

I didn't miss any step nor did I close the terminal, but still touchpad gestures don't work!
Thanks in advance.

EDIT:
Contents of /home/vaishnavi/.config/fusuma/config.yml:

swipe:
  3:
    left:
      command: "xdotool key Alt+Right" # History forward 
    right:
      command: "xdotool key Alt+Left" # History back
    up:
      command: "xdotool key Super" # Activity
    down:
      command: "xdotool key Super" # Activity
  4:
    left:
      command: "xdotool key Ctrl+Alt+Down" # Switch to next workspace
    right:
      command: "xdotool key Ctrl+Alt+Up" # Switch to previous workspace
    up:
      command: "xdotool key Ctrl+Alt+Down" # Switch to next workspace
    down:
      command: "xdotool key Ctrl+Alt+Up" # Switch to previous workspace
pinch:
  in:
    command: "xdotool keydown Ctrl click 4 keyup Ctrl" # Zoom in
  out:
    command: "xdotool keydown Ctrl click 5 keyup Ctrl" # Zoom out
  • Could you test what I proposed? It is as simple as running without sudo. – sancho.s ReinstateMonicaCellio Sep 22 at 13:48
  • Would you mind posting the contents of your /home/vaishnavi/.config/fusuma/config.yml? – sancho.s ReinstateMonicaCellio Sep 24 at 6:30
  • @sancho.sReinstateMonicaCellio I added the contents of config.yml – Gopal S Sep 24 at 6:40
1

As per this post, when you run fusuma with sudo the config file is not properly (whatever that means) read. You have to run it as your regular user. I am not sure in which cases using sudo would work or not. As per the voting of the answer you linked, it does work in many cases.

Note that in a post by the developer of fusuma, it is started without sudo. It is worth reading that post, since it mentions a couple of points that may be crucial:

  1. You "need to log out and log in (or restart) from X".
  2. fusuma -d keeps it running in the background when the terminal is closed.

Consistently, in the Github readme page, which contains the installation instructions linked in the answer you linked, fusuma is also run without sudo. I wouldn't know why the answerer Rachit Kinger uses sudo.

You can take advantage of libinput debug-gui in this or other occasion, as also mentioned in that same thread.

| improve this answer | |
  • Thanks for your answer, but it didn't work – Gopal S Sep 23 at 5:14
1
+50

Looking at the output you have attached here, I think the fusuma is configured successfully actually. Here I'm attaching my output file. and after this i tried to use my gestures and it works completely fine. Here is the screenshot.

So, in your case maybe you haven't followed the tutorial carefully or it may be that your dependencies are not completely installed or you haven't configured your config.yml file.

I suggest you to again go through that complete process or check your config.yml file first, Moreover you can just install all the dependencies like

$ sudo apt-get install libinput-tools  
$ sudo apt-get install xdotool 
$ sudo apt install ruby  
$ sudo gem install fusuma  

And now one more suggetion you can try is that first you find your default path of fusuma and run that from there like.

$ whereis fusuma

let's say the output will be something like /usr/local/bin/fusuma (this is in my case)

and run this like

$ sudo /usr/local/bin/fusuma

also you can try to run this as without using sudo privileges, maybe it is causing some issue, but I'm not completely sure about this.

Hope this may help.

| improve this answer | |
  • After a reinstallation, this worked, Thanks! – Gopal S Sep 27 at 3:13
  • you are welcome...!! – Abhyam Gupta Sep 27 at 16:31
1

Please paste output of $ libinput debug-events with 3 finger swipe.

If you find lines related to swipe in logs, fusuma can detect gestures.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.