1

I just upgraded my laptop from 18.04.5 to 20.04 and my keyboard and mouse have stopped working. The keyboard works in BIOS and when entering my password for cryptsetup but as soon as it's all fully loaded up, the mouse and keyboard stop working. I've tried using the terminal/command line to enter sudo alt-get install xserver-xorg-input-all as suggested on a few sites. This has not helped at all! Does anyone have any suggestions? I'm completely lost without my laptop!! Thanks in advance.

  • 2
    Bug in kernel 5.4.0-44 and 0-45 so far. External keyboard or dropping down to kernel 5.4.0-42 works in recovery mode. – crip659 Sep 13 at 21:05
  • Thank you @crip659 - feels much better to know there's a "known" problem. Will a USB mouse work as well as a USB keyboard? I'm also not sure how to play with kernels in recovery mode! Bit of a n00b, I'm afraid! – MisterChrisL Sep 14 at 8:54
  • Was a bit fast suggesting it is this bug. It sounds like it, but so far for HP and Acer's using the 5.4.0-45 Kernels. Should list your computer and your kernel to make sure. uname -a in terminal for kernel. External USB or wireless keyboards and mice do seem to work. – crip659 Sep 14 at 11:29
  • @crip659 Thanks for the help - I think this is everything, I just did a quick copy and paste of the information that came up when I entered uname -a - so I have an HP-Stream-x360-Convertible running 5.4.0-47-generic #51-Ubuntu SMP. Does this mean anything? – MisterChrisL Sep 14 at 19:53
  • Just that bug does not seem to be fixed yet. Would try to check updates so they don't try to remove kernel 5.4.0-42(last known to have keyboard work). Might not have it since you just upgraded. – crip659 Sep 14 at 20:39
1

Right! Have found a workaround. Have access to GNU GRUB menu as i have dual boot with windows. From There if i select 'advanced options' instead of the default and boot from Linux 5.4.0-42-generic i have access to all keyboard and trackpad features.

| improve this answer | |
0

Maybe it can be because of broken packages, try to fix files of ubuntu by going to the recovery mode and there will be many options to fix packages,boot file etc.

Grub Loader>advanced ubuntu settings>Recovey version a,b,c

| improve this answer | |
0

Ubuntu 20.04 / CHUWI AEROBOOK Have the same issue, although in my case the keyboard stopped working after a few reboots right after install and config.

  1. Still works with USB keyboard after normal boot
  2. Laptop keyboard works after a recovery boot, but display settings are gone - no brightness control, no external monitor.
  3. Tried most of the solutions in posts online to no effect.
| improve this answer | |
  • Thanks - good to know it's not just me! Just to clarify (I'm quite new to Ubuntu), what is a recovery boot? – MisterChrisL Sep 14 at 8:49
  • When grub shows you have choice of booting into main/most recent kernel of Ubuntu(boot into Ubuntu) or the next line down is recovery. If you do not have grub set to show on loading/startup(only ubuntu on computer) might need to hit shift button a few times when computer logo shows on power up. – crip659 Sep 14 at 10:38
  • 1
    @MisterChrisL Try this - Access to GNU GRUB. From There select 'advanced options' instead of the default and boot from Linux 5.4.0-42-generic i have access to all keyboard and trackpad features since. – Invisible Man Sep 14 at 10:54
  • 1
    Right, as @crip659 said, but instead of selecting any of the recovery modes select the previous kernel version 5.4.0-42-generic.This worked for me – Invisible Man Sep 14 at 11:07
  • Thanks mate, and @crip659 - I've got an old wired USB mouse and keyboard plugged in and working, will try to fiddle around with kernels tomorrow! Hopefully this will be fixed pronto? – MisterChrisL Sep 14 at 19:56
0

The problem is Ubuntu thinks your PC is a tablet and diables the keyboard. The fix below works if the following command gives you any number that is not 31 or 32.

cat /sys/class/dmi/id/chassis_type

How to fix this: (from https://askubuntu.com/a/1282269/558457)

There is a bug in recent kernels that disables some laptop keyboards. Mainly Acer and HP so far. Can usually go to recovery and boot from kernel 5.4.0-42 or use an external keyboard.

Blacklisting the intel_vbtn kernel module is a workaround for this, as seen in Why my laptop's keyboard screwed up since kernel 5.4.0-47 till 5.8.0-20

To implement this, you can either create a new file in /etc/modprobe.d with the suffix .conf or use the main blacklist.conf file. The former may be preferable, since you can then just delete the file when it is no longer required (i.e. when the bug is fixed):

sudoedit /etc/modprobe.d/blacklist-intel_vbtn.conf

Add a line to the file, optionally with a comment explaining why you are doing this

# bug in module breaks keyboard, so don't load it
blacklist intel_vbtn

Save the file, exit and reboot.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.