0

I was trying to install NVIDIA drivers today, but I didn't realize there are already the default drivers installed. I downloaded a ".run" file from NVIDIA website and tried to install the drivers. It said that it needs to disable nouveau. Then, it created 2 (or more, I don't know) files that should blacklist nouveau. The installation failed after that. I rebooted my laptop and tried to run the installation again. It failed, so I gave up. I deleted the 2 files the installer mentioned I should delete to enable nouveau again:

/usr/lib/modprobe.d/nvidia-driver-disable-nouveau.conf
/etc/modprobe.d/nvidia-driver-disable-nouveau.conf

Then, I rebooted my system. I saw some lines on the screen for a short time, then I got a black screen. I can still switch to command line TTY.

Is there a way to fix this? If not, can I download those config files I deleted somewhere?

4
  • The installer will blacklist the nouveau driver. The best way would be to uninstall the driver and hope that the blacklist will be updated accordingly. Else you should remove the entry blacklist nouveau in one of the conf files that are located in /etc/modprobe.d.Update the initramfs aftwards
    – kanehekili
    Sep 13, 2020 at 21:05
  • Thanks for your response. I'll try this today and let you know. This is really strange. I even didn't update initramfs after deleting those 2 files. But I've tried it and it didn't help.
    – adazem009
    Sep 14, 2020 at 3:49
  • @kanehekili I've managed to solve this issue. See my answer below.
    – adazem009
    Sep 14, 2020 at 14:58
  • Well, that was exactly what I meant. Remove the "foreign" driver and install the one from the repos. I didn't know it worked your way.. Thanks for clearing up
    – kanehekili
    Sep 14, 2020 at 17:49

1 Answer 1

2

After some searching, I found a way to install proprietary NVIDIA drivers from command line.

sudo apt update && sudo apt install nvidia-driver-390

This actually solved my problem. I even didn't have to reboot my laptop. systemctl restart gdm3 brought me straight to GNOME login screen.

I hope this helps someone who has accidentally bricked the system by using the installer :)

1
  • JFH, having GeForce GT 710, the screen was freezing randomly (i.e. every hour) on kubuntu 20.04. The programs themselves were continuing to work except the screen graphics. Tried to install new drivers via nvidia drivers installer, but it was failing with the mentioned error and as turned out was suggesting not the latest drivers (364). Your approach helped and now after updating to nvidia-driver-390 via apt, there is no freezes noticed during the rest of the day. Thanks. Configuration: i5-3470, gt710 2gb, P8H61-M LX Jul 5, 2021 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.