2

I am using .deb package downloaded from Oracle website, and I even had it installed properly earlier. But now there's not really any change to the system however it throws below error. Also I can see the icon of it in the menu but it does not open. Using Ubuntu 20.04.1 What could be the problem?

$ sudo dpkg -i Software/virtualbox-6.1_6.1.14-140239~Ubuntu~eoan_amd64.deb
Selecting previously unselected package virtualbox-6.1. 
(Reading database ... 240840 files and directories currently installed.)
Preparing to unpack virtualbox-6.1_6.1.14-140239~Ubuntu~eoan_amd64.deb ... 
Unpacking virtualbox-6.1 (6.1.14-140239~Ubuntu~eoan) ... 

dpkg: dependency problems prevent configuration of virtualbox-6.1: 
virtualbox-6.1 depends on libqt5opengl5 (= 5.0.2); however:  
Package libqt5opengl5 is not installed.  
virtualbox-6.1 depends on libqt5printsupport5 (=5.0.2); however:   
Package libqt5printsupport5 is not installed.  
virtualbox-6.1 depends on libsdl1.2debian (= 1.2.11); however:  
Package libsdl1.2debian is not installed.  
virtualbox-6.1 depends on python (<< 2.8); however:  
Package python is not installed. 
virtualbox-6.1 depends on python (= 2.7); however:   
Package python is not installed.  
virtualbox-6.1 depends on python:any (= 2.6.6-7~);
however:
dpkg: error processing package virtualbox-6.1 (--install):  dependency problems - leaving unconfigured 
Processing triggers for systemd (245.4-4ubuntu3.2) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ... 
Processing triggers for mime-support (3.64ubuntu1)... 
Processing triggers for hicolor-icon-theme (0.17-2) ... 
Processing triggers for shared-mime-info (1.15-1) ... 

Errors were encountered while processing:  virtualbox-6.1
6
  • 1
    What OS & release are you using? Why do I see eoan or 19.10 messages in your post? The virtualbox found in Ubuntu repositories for Ubuntu 20.04 is also 6.1 (packages.ubuntu.com/focal/virtualbox)
    – guiverc
    Sep 13, 2020 at 10:41
  • @guiverc it is 20.04.1 Sep 13, 2020 at 10:47
  • 1
    Your content is hard to read (I tried to change the quoting you used to {} code block, but it didn't have line breaks in it so you'll need to re-paste. In your post you'll see references to "6.1.14-140239~Ubuntu~eoan", eoan is the code name of Ubuntu 19.10 so that package should never have installed on a 20.04 system (it's for the wrong release; 20.04's code name is focal). You need to remove it (your output is too hard to read so there maybe more than just that)
    – guiverc
    Sep 13, 2020 at 10:50
  • @guiverc unfortunately I found only packages listed in this site virtualbox.org/wiki/Linux_Downloads for ubuntu 19.10 and 20.04 Sep 13, 2020 at 10:57
  • As per my first comment, you could have just sudo apt install virtualbox and had your system automatically download & install the 6.1 version of virtualbox, the version tested for your release. (the first link shows it's in multiverse repository, at most you would have needed to enable that repository, if it wasn't selected/enabled already)
    – guiverc
    Sep 13, 2020 at 11:02

1 Answer 1

7

Read output. "dependency problems"

libqt5opengl5 libqt5printsupport5 libsdl1.2debian ... etc.

sudo apt install -f -y
1
  • This doesn't work for me. I get the exact same error as OP, and when I run this command, it doesn't install any dependencies but rather uninstalls virtualbox: The following packages will be REMOVED: virtualbox-6.1. Mar 6, 2021 at 18:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.