Hp Laserjet 1108, HP Laserjet 1007, HP laserjet pro M1213nf MFP, Canon Pixma 5070, no printers are working after installing Ubuntu 20.04. they all were working in Ubuntu 18.04. it says:

File "/usr/lib/cups/filter/hpcups" not available: No such file or directory.

however terminal says:

hplip is already the newest version (3.20.3+dfsg0-2)

I also tried hplip-gui, and also reinstalled Ubuntu total 4 times over 2 different laptops but still printer is not working.

  • Are you missing printer-driver-hpcups package? How are you installing hplip: apt or the one from HP website? Sep 13, 2020 at 9:29
  • in one computer i have not installed hplip, only installed ubuntu 20.04 and only run update . in other computer i installed hplip from hp website. sudo apt install cups says "cups is already the newest version (2.3.1-9ubuntu1.1)." Sep 13, 2020 at 9:58
  • sudo apt install printer-driver-hpcups "printer-driver-hpcups is already the newest version (3.20.3+dfsg0-2)." Sep 13, 2020 at 10:46
  • Is that file present there? ls -lA /usr/lib/cups/filter/|grep cups Sep 13, 2020 at 11:16
  • avi2@Off-UB:~/Desktop$ ls -lA /usr/lib/cups/filter/|grep cups "avi2@Off-UB:~/Desktop$ " Sep 13, 2020 at 11:35

2 Answers 2


You're probably missing the shared library /usr/lib/cups/filter/hpcups, according to Debian file list the package printer-driver-hpcups (https://packages.ubuntu.com/focal/printer-driver-hpcups/) has it. So if you installed hplip from the HP website package, uninstall it using that setup. If via apt or preinstalled in Focal do this:

sudo apt purge hplip hplip-gui printer-driver-hpcups

Make sure to note what gets removed (read output) do an apt autoremove if necessary. Then reinstall them, this way it's less likely to have a broken system.

sudo apt update 
sudo apt upgrade 
sudo apt install hplip hplip-gui printer-driver-hpcups <+ anything that's removed in the last steps>

Then run the printer setup wizard after connecting your printer, make sure CUPS sockets are activated, CUPS services are running; select the ppd file if necessary and you can complete the wizard.

  • Hay, thank you, this solution saved me a lot of headache under ubuntu 20.4.1 LTS. The "L" in "LTS" actually means that I don't want to care for that problem for a long time and you've contributed to that :)
    – Michael
    Jan 18, 2021 at 19:05
  • This is all very helpful: thanks for that. Just one more piece of information would be useful: what is the name of the "printer setup wizard" executable? (I'm doing this remotely, on a headless machine.) Feb 25, 2021 at 17:33

With my Epson Stylus Photo R300 printer, I tried everything I could think of until I realised Ubuntu 20.04 was disabling printers at every reboot. Then "System Settings" | "Printers" / Double click on your printer / Select "Policies" and check the "Enable" box. This has to be done after each reboot!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.