0

I have been increasingly interested in Linux machines and decided to download Virtual Box to run Ubuntu on my windows 10 laptop. However, every time I try to start the virtual linux, it keeps giving me the following error:

Failed to open a session for the virtual machine Linux.

Not in a hypervisor partition (HVP=0) (VERR_NEM_NOT_AVAILABLE).

VT-x is disabled in the BIOS for all CPU modes (VERR_VMX_MSR_ALL_VMX_DISABLED).

Result Code: E_FAIL (0x80004005) Component: ConsoleWrap Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

I went into settings to see if I can find something there however any change I make is faced by another error:

Invalid Settings Detected: The hardware virtualization is enabled in the Acceleration section of the System page although it is not supported by the host system. It should be disabled in order to start the virtual system.

However, when I went to the Acceleration section and disabled the checkbox for Nested Paging (the only option under Hardware Virtualization), the error was not resolved and I could not save the changes.

Does anyone have any ideas what is going on?

Thank you in advance for any help

EDIT: It turns out that the VT-X command is under the System -> Processor tab. However, that button is unchecked and grayed out for me...

0
0

The "VT-x" setting in Virtualbox is available under the System -> Processor tab rather than the System -> Acceleration tab.

You may also want to check in your BIOS if VT-xAMD-V support is available but just currently disabled. Most modern computers/CPUs have this feature at this point.

1
  • That button is grayed out for me - I can't check the checkbox ... (it is currently unchecked) – 0x435d2d Sep 13 '20 at 21:39
0

The most probable reason for this error is that your computer does not have Virtualization enabled.

How do you enable it? Restart your computer, and at first signs of startup, repeatedly press the "F10" button. This will bring up a menu with a bunch of options. Navigate through the menus until you find the "Virtualization" feature. Make sure it is enabled and save and exit.

Now, your virtual machine should work fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.