1

I am using Ubuntu 20.04.1 LTS. I have installed the latest version of Firefox. However, Firefox does not play Vimeo videos. The video's title frame downloads and the loading button displays but the video never starts. Interestingly, the video plays very well in Chrome.

I have already done what is recommended in the following webpages:

  1. How to Install and Use FFmpeg on Ubuntu 18.04
  2. Vimeo Troubleshoot player error messages
  3. Mozilla Support: Firefox is not playing videos on websites

But none of these solutions have worked. Could someone help me on this? I prefer using Firefox to Chrome.

2
  • 1
    It is working perfectly fine for me with firefox 80.0.1, Ubuntu 20.04.1 LTS. Try updating the system...
    – digiwizkid
    Sep 12 '20 at 7:38
  • try sudo apt install ubuntu-restricted-extras
    – kannzzmm2
    Sep 12 '20 at 11:29
1

This here did the trick for me:

sudo apt-get install ffmpeg

Found at Mozilla Support Forums

1

Workaround (crap "answer"):

If I have an audio problem, firefox videos won't play...
Being too lazy too look into the actual problem, I often have to pulseaudio -k or pkill pulseaudio and videos start immediately after pulseaudio respawns (if they were already in the process of attempting to play).

(My 20.04 VM experiences regular audio problems with the audio randomly cutting out)

0

I also prefer Firefox to Chrome, but Chromium/Chrome is better than Firefox on multiple video sites, not just Vimeo. I stick with Chromium for playing videos because it's both faster loading for many video websites and less glitchy when playing videos than Firefox.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.