4

I have my hard drive encrypted with ubuntu 20.04, using the installer, When I updated to kernel 5.4.0-47-generic , instead of asking for my password it sits at

cryptsetup: waiting for encrypted source device UUID=......

If I go under advanced options and boot to kernel 5.4.0-42-generic everything works just fine

4
  • 1
    Hello! can you show your /etc/crypttab and do you use a unencrypted boot partition and the rest is full encrypted or do use something else?
    – moep
    Sep 11, 2020 at 21:07
  • nvme0n1p6_crypt UUID=07c67889-bcc6-4417-a8f8-a420c6c7aee9 none luks,discard
    – Tim Holum
    Sep 13, 2020 at 16:34
  • Ok, that looks fine. How does your layout from your nvme? Is it uncrypted boot and the rest encrypted?
    – moep
    Sep 13, 2020 at 18:14
  • Device Start End Sectors Size Type /dev/nvme0n1p1 2048 1085439 1083392 529M Windows recovery environm /dev/nvme0n1p2 1085440 1288191 202752 99M EFI System /dev/nvme0n1p3 1288192 1320959 32768 16M Microsoft reserved /dev/nvme0n1p4 1320960 1084590102 1083269143 516.6G Microsoft basic data /dev/nvme0n1p5 1084592128 1087520767 2928640 1.4G Linux filesystem /dev/nvme0n1p6 1087520768 2000408575 912887808 435.3G Linux filesystem
    – Tim Holum
    Sep 21, 2020 at 10:59

1 Answer 1

1

I'm experiencing the same problem. This seems to be a bug https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1894860.

My solution at the moment is when booting.

  1. open the grub menu.
  2. Select Advanced options for Ubuntu.
  3. Select Ubuntu, with Linux 5.4.0-42
1
  • as of 5.11, this doesn't work. groan Apr 30, 2021 at 7:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.