I just installed a fresh copy of Mythbuntu 12.04. I installed it as a combined frontend and backend. I ran through the configurations, accepting all defaults except for two items:

  • I set the hostname to the server's IP
  • I checked the checkbox to enable network remote controls

I then rebooted. When I try to connect via mythmote, I get "connection refused" and "connection timed out" errors. What I have done to diagnose the issue:

  • Reboot
  • Re-run configuration without changing any settings
  • Disable IPv6 (ala /proc/sys/net/ipv6/conf/all/disable_ipv6)
  • Disable ufw
  • Run Wireshark, which reports that a TCP SYN arrives at the server, and the server sends a TCP RST in response. Prior to disabling ufw the server would not even send the TCP RST

The settings I have for mythmote are:

  • Name: Gamma (this is my third server)
  • Address:
  • Port 6546
  • MAC: (Not filled in, I don't need WOL)

If I switch to a TTY on the server, I can telnet 6546 and get to the network remote control interface. If I try the same via telnet 6546 I get a connection refused.


I just now found out (thanks to your sleuthing) that a temporary solution is to port forward with ConnectBot.

Port Forwarding is a bit tricky, there's a menu entry, "Port Forwards", that shows up once you're connected. You should also be able to get to it by "long pressing" a host before you connect.

This Port Forward screen is empty. To add entries to it, press the menu button and click "Add port forward"

Once you have port forwarding setup, you'll need to modify the mythmote to connect to '' now that you're actually connecting to the port on your android (that is a "tunnel" to the external host).

Edit: since this post has gained some traction, let me consolidate:

1) a simplier solution is to run sudo mythtv-setup as the user that runs mythtv. Then configure the backend address to be the external one.

Also note the following bugs:

| improve this answer | |
  • I am having the exact same issue. Can you provide more detail on how to port forward? I have installed ConnectBot, and can create an SSH login to my Mythbuntu computer, but I don't see how I get the two programs to relate. – Questioner Jun 20 '12 at 9:07
  • @DaveMG I wanted to add screenshots (but didn't bother to make any myself) since I'm sure the confusion is the blank screen when you try to add the port forward. Hopefully my edit is helpful. – isaaclw Jun 21 '12 at 12:30
  • Thanks for the response. I've found the right screen though I'm unsure of what settings to use. But in any case, I think it might be that in my case the problem is on the Mythbuntu side: askubuntu.com/questions/153498/… – Questioner Jun 21 '12 at 16:16
  • Try these values: Type: local Source port: 6546, Destination: localhost:6546 Also like Huckle said, try telnet 6546 from commandline on your mythbuntu computer that you're trying to connect to. – isaaclw Jun 21 '12 at 17:16
  • telnet 6546 does work, and shows me the "MythFrontend Network Control". However, with the port forwarding settings you suggested, I'm not sure what happens next. I set it up and it's running... but mythmote is stull giving me a connection refused error. Is it enough to just have the port forwarding running, or is there something else that needs to be done to connect the two apps? – Questioner Jun 21 '12 at 17:53

Can't say I have the same problem, however it seems similar: On atom box running latest 12.04.1 ubuntu kernel.

When boot up I exit frontend. and then go to control-centre. Open it and select Infrared control and remotes; I select Android and then apply - it says nothing to do (this is OK).

I then leave control-centre in this state (it seems there is a bug as the code to wroite out the selection does not work).

Goto menu and select front-end and wait for start. Select watch and away you go. Mythmote now connects!!!

| improve this answer | |

The other answer talked about port forwarding, but if that is tedious (it is for me), then you can actually fix the issue by reconfiguring mythtv.

Close the mythtv interface, and open a terminal.

Run sudo mythtv-setup as the user that normally runs the frontend.

Enter General Configurations, and change the IP address to match the external, network IP address. In my case I set the ipv4 address, and left ipv6 blank.

Since I have droidwall installed, I also had to make sure that mythmote was unblocked.

| improve this answer | |

Try setting the parameter NetworkControlEnabled to 1 for your FE node in mythweb and then restart mythfrontend. I just installed a fresh copy of mythbuntu 12.04 and this was set to 0 by default.

| improve this answer | |

Edit the /etc/mythtv/config.xml file...

After the entry "<"Frontend">" add (lose the quotes, I had to add them to have the brackets)

"<"LocalHostName">"enter your local ip here"<"/LocalHostName">"

I also added these commands as root:

iptables -I INPUT -p tcp --dport 6546 -i [+] -j ACCEPT
iptables -I INPUT -p tcp --dport 6546 -i use your ip here -j ACCEPT

Then go to your frontend, and if you have the check mark for remote connections, uncheck, exit the frontend, restart the frontend, go back in, recheck the box, then exit the frontend, and restart, it should work.

The answer was on the MythTV website, they are using the config.xml file, which does not list a hostname on a frontend install, so you need to go in and ADD it otherwise the box only listens on the loopback address. I have done this on 2 frontends so far, and worked both times, I have one more to attend to, but it uses a USB IR receiver, so I actually only need it to play blu-ray discs because the Vista remote won't hit the play button. Best of luck!!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.