0

I've installed Nvidia 450 on new installation of Kubuntu 20.04.1.

Prime Render Offload works in manual mode with __NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia

But nvidia-settings says prime is not supported. And so I have no prime entry in the nvidia window as you can see below.

So I think the swith between integrated and nvidia GPU will not be automatic and the "on demand" does not work.

What is wrong ? Thank you for your help.

Computer : Asus A17-TUF766IU-H7074T

OS Details : Kubuntu 20.04.1 with mainline 5.8.8 kernel Nvidia Driver version : 450.66 Desktop Environment : Plasma Window Manager : KDE

Hardware Details Processor : AMD Ryzen 4800H GPU : GeForce GTX 1660 Ti 6 Go

meloli@Asus-A17:~$ __NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia glxinfo | egrep "(OpenGL vendor|OpenGL renderer|OpenGL version)"
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 1660 Ti/PCIe/SSE2
OpenGL version string: 4.6.0 NVIDIA 450.66

meloli@Asus-A17:~$  glxinfo | egrep "(OpenGL vendor|OpenGL renderer|OpenGL version)"
OpenGL vendor string: X.Org
OpenGL renderer string: AMD RENOIR (DRM 3.38.0, 5.8.8-050808-generic, LLVM 10.0.0)
OpenGL version string: 4.6 (Compatibility Profile) Mesa 20.0.8

And

meloli@Asus-A17:~$ nvidia-settings
 
(nvidia-settings:6099): GLib-GObject-CRITICAL **: 14:05:53.205: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

ERROR: nvidia-settings could not find the registry key file. This file should have been installed along with this driver at /usr/share/nvidia/nvidia-application-profiles-key-documentation. The
       application profiles will continue to work, but values cannot be prepopulated or validated, and will not be listed in the help text. Please see the README for possible values and
       descriptions.

** Message: 14:05:53.270: PRIME: No offloading required. Abort
** Message: 14:05:53.271: PRIME: is it supported? no

enter image description here

0

There is no automatic switch in linux (automatic switch only works in windows) and use of Nvidia GPU can only be done by manually add the prefix before the command.

For Vulkan :

__NV_PRIME_RENDER_OFFLOAD=1 __VK_LAYER_NV_optimus=NVIDIA_only
__NV_PRIME_RENDER_OFFLOAD=1 __VK_LAYER_NV_optimus=non_NVIDIA_only

For GLX + OpenGL

__NV_PRIME_RENDER_OFFLOAD=1 __GLX_VENDOR_LIBRARY_NAME=nvidia
__NV_PRIME_RENDER_OFFLOAD_PROVIDER=NVIDIA-G0 __GLX_VENDOR_LIBRARY_NAME=nvidia

But there is a little bug I reported in launchpad : PRIME Profiles are not shown in nvidia-settings with 450 driver. https://bugs.launchpad.net/ubuntu/+source/nvidia-settings/+bug/1895327

EDIT PRIME Profiles are now in the last drivers.

Source :

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.