4

I had an application (in case it matters: LibreOffice Calc] in full-size mode. I then clicked the middle of the three buttons of the top right to adjust the size. When I did that, the window became minimum size, literally a vertical line.

I panicked and alt-tabbed, and now I can't even find the vertical line anymore. Opening new windows in that application opens all of them hidden to me, and closing/reopening or even restarting the OS doesn't help. I don't know how to resize my invisible windows anymore. Here's the preview of the windows in the application launcher: a vertical line (that I don't find on my screen anywhere if I click this).

enter image description here

7
  • Can you make the window full-size again by right-clicking the preview and then selecting "maximize"?
    – raj
    Sep 11, 2020 at 13:00
  • That's also probably a bug in LibreOffice and you should consider reporting it. It also happened to me a few times, however the window was not reduced to vertical line, but to a very small square, which I could resize manually. But I'm using GNOME Flashback and not GNOME shell like you, that could make a difference.
    – raj
    Sep 11, 2020 at 13:07
  • @Raj if I rightlick the preview, "nothing happens" - it's I think on my system identical to a left click, supposedly its opening the window.
    – FooBar
    Sep 11, 2020 at 13:47
  • And rightclick on the icon? Does it do anything?
    – raj
    Sep 11, 2020 at 13:48
  • Is deleting your LibreOffice profile an option for you? It should restore all LibreOffice settings back to default, including window sizes.
    – raj
    Sep 11, 2020 at 13:51

2 Answers 2

4

I did an investigation in LibreOffice version 6.4 and found out that the following line in file ~/.config/libreoffice/4/user/registrymodifications.xcu stores the window coordinates for calc:

<item oor:path="/org.openoffice.Setup/Office/Factories/org.openoffice.Setup:Factory['com.sun.star.sheet.SpreadsheetDocument']"><prop oor:name="ooSetupFactoryWindowAttributes" oor:op="fuse"><value>0,37,800,600;1;0,0,0,0;</value></prop></item>

You have to have all LibreOffice application windows closed before editing this file.

Open this file and try to locate this line. In my file it was at line position 1258. Note that the values inside <value>…</value> will be different for you. You can change yours to the values displayed above, which will give you a roughly 800×600 application window located at the upper left corner of your screen.

After you save the file, open calc and resize its window according to your needs.

1
  • 2
    This worked. To humor you, here's the coordinates that were stored on that line in my file: <value>3118,1394,1,26;1;0,0,0,0;</value>. No wonder I wouldn't see even the minimized icon.
    – FooBar
    Sep 12, 2020 at 9:51
0

Just had the same problem with xubuntu 21.10. Changing the config values didn't help, but raj's suggestion to delete all under .config/libreoffice worked nicely.

2
  • Please don't add "thank you" as an answer. Once you have sufficient reputation, you will be able to vote up questions and answers that you found helpful. - From Review
    – guntbert
    Jan 5 at 17:36
  • This looks like a "thank you" comment, but is actually a valid answer: it transforms information currently only in a comment to the question, and phrases it as a (short) answer.
    – FooBar
    Jan 6 at 11:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.