0
  • Host OS : Kubuntu 20.04
  • Virtualbox Version : 6.1.16
  • Guest OS : Kubuntu 20.04
    • Graphic Controller : VMSVGA, no 3d accel
    • video memory : 32mb

When I run Virtualbox Guest OS (latest virtualbox guest addtion installed), Host web browsers(Firefox, Vivaldi, Chrome) cannot load youtube videos. But when I turn off the virtualbox, youtube video plays well.

What's happening here?

1

Usb speakers/headset device in play.
On the host, usb speaker/headset device is filtered to the virtual box guest...
Turn the guest on, the guest takes control of the the usb device.
Sound gets disabled on the host because there is no device anymore...
No sound, no video play on the host.
Turn the guest off, the host gets control of the usb device again...
Video plays on the host again, now that there is a sound device available.

6
  • but I don't use usb speaker/headset??. Anyway I tried to disable the VM's usb interface, but failed. Virtualbox did not allow disabling usb interface. – KwonNam Sep 11 '20 at 23:14
  • well... you shouldn't have to disable a usb filter(at first)... you have to ENABLE its use to begin with... and if you don't want it used anymore you just uncheck(or remove) it.... "Device Filters:" goes back to saying "0 active".... but, this is all irrelevant because you say you don't use a usb speaker/headset... On my host I definitely see my audio device (headset) disappear under Sound Settings when I turn my guest on... is the same happening for you? – WU-TANG Sep 11 '20 at 23:40
  • I guess you're right. I couldn't find how to configure usb, anyway, after I disabled VM's audio, it works perfectly. I do not need VM's audio. – KwonNam Sep 12 '20 at 7:39
  • Interesting, but I think you may have stumbled on to your own answer based on what I have told you. Mine was based on USB filter behavior. It seems you are saying that the same thing happens when the VMs audio is enabled, which is something I have NEVER seen happen in virtualbox. I have the audio enabled on all 3 of my VMs on this very host and I have never had them interfere with any host in any past use. Perhaps try turning it back on but selecting one of the other options as far as "Host Audi Driver", "Audio Controller", and/or "Enable Audio Output"... playing with those may help. – WU-TANG Sep 12 '20 at 14:03
  • and just for reference: as far as usb... on that same GUI, under USB. There is the option to "Enable USB Controller" and you can select "1.1", "2.0", or "3.0" when the guest is off. You can add/remove/edit usb filters by clicking the button on the right. If you haven't done this it should be empty. and on the main display for the VM options, under "Network" and above "Shared Folders", "USB" should list "Device Filters: 0(0 active)" – WU-TANG Sep 12 '20 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.