1

I have a brand new asus laptop with intel AX200 series wifi, and AMD renoir (4000 series) APU. Upon trying to install Ubuntu 20.04 from a live usb stick, I faced a few problems:

I'm stuck on a very low resolution: should be fixed with an amd driver install, so no big deal.

Sadly, I don't have any wifi adapter either, meaning I can't update my graphics drivers or download the updates during the install.

I found a few users reporting the same problems, and claiming it was included by Intel on the Linux kernels 5.1 and higher (see here on intel.com, link found from Intel wifi Support for AX200 (Cyclone Peak))... It should be working in that case, since uname -r returns 5.4.0.42, but I don't have any form of network connectivity apart from Bluetooth, so I'm stuck on a non working install stick.

I tried loading the intel ucode file from the first link with no success as it seems to require a reboot which I can't perform on a live stick for obvious reasons.

I found traces of iwlwifi on the filesystem of the stick, under /lib/firmware, so i assume that the iwlwifi package is installed. Question is how I can load it to actually have wifi.

Any idea as to what I can do to get out of this situation? Thanks in advance

4
  • Testing your network connectivity and other hardware compatibility before installing is precisely why the installer has a "Try Ubuntu" environment.
    – user535733
    Sep 10 '20 at 21:47
  • 1
    @user535733 Thats what i mean, i need a linux distro working and im trying things to get it working. The try environement didnt allow me to do much as i couldnt get the driver installed.
    – Bruh
    Sep 10 '20 at 22:34
  • Things get much easier, if you can somehow connect via a wired network, ethernet. Maybe you can borrow some cable or carry your computer to some location, where you can connect via wire. -- Wired network will usually work without any tweaks, and that way you can get proprietary drivers for wireless network and for graphics. But be aware, that proprietary drivers work only in installed systems, not in live or persistent live systems.
    – sudodus
    Sep 12 '20 at 10:50
  • @Bruh, Thanks for sharing your solution :-)
    – sudodus
    Sep 12 '20 at 17:03
1

Ok i would appear that despite my verification, windows fast boot was still enabled, and was causing interference with my wifi adapter. Disabling it from windows solved the problem. Wifi worked and from here i could also get my graphics driver working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.