Today I saw that I could update Discord on Ubuntu 20.04.1 LTS to version 0.0.12. The problem now is that in the Ubuntu Software the newest version is 0.0.11. I also cannot open the .deb file that discord downloads for the update in Ubuntu Software. I also tried to uninstall and reinstall Discord through Ubuntu Software. I also tried to update through the command line with the snap. I used snap refresh discord and it said that there were no updates available.

The message I get every time I open Discord:


  • 5
    This question should be re-opened. The fundamental problem here is that Discord's internal update mechanism does not complete quickly: you click on the "Download" button shown above, but nothing seems to happen. Download a .deb from the Discord website and installing it from the terminal is one possible solution, but there may well be a better solution. E.g. maybe Discord is looking for dpkg in the wrong place - there are many possibilities, but we won't know if the question is closed. The issue is still not fixed with 0.0.13 BTW.
    – Matthew
    Dec 5, 2020 at 10:02
  • 1
    It seems in the begining you install Discord using .deb file, Even I did same but now this what I did to get rid of this update thing. ---- 1) First find discord using dpkg -l | grep discord ---- 2) Remove previous Discord installed through dpkg using apt-get --purge remove discord
    – SMshrimant
    Dec 6, 2020 at 18:32

3 Answers 3


If you've installed the snap version before, update it with the command sudo snap refresh discord

Else if you've installed discord from the official website, update it through the following steps.

  1. Go here to download the latest .deb file.
  2. Open terminal and go to the folder where you've download the file.
  3. Install it using sudo apt install ./<package name>
  • 1
    is it advisable to uninstall the previous version first or is it fine just installing the lastest .deb every time?
    – Nono
    Sep 11, 2020 at 11:49
  • 1
    You can just install the latest version, using the command I gave you and the package manager will take care of the rest.
    – Heisenberg
    Sep 11, 2020 at 12:31
  • can i also install it in snap? Because now i have two versions, one older snap version and one new apt version. I also need do login again in my discord account.
    – ch1ll
    Dec 5, 2020 at 9:50
  • 1
    @Heisenberg I hope there was no offense taken, I thought it was an okay answer before, I was mostly commenting for people that were stuck the way I was where the snap was not available yet. Then they (me, yesterday) have to either wait or decide to un-snap and go manual. Cheers either way, we're all just trying to help
    – Mike Hardy
    Dec 5, 2020 at 16:27
  • 1
    @MikeHardy Nah, I don't care much about snaps. I realized that a lot of people must be using snap version so It would be better to add the snap update thingy.
    – Heisenberg
    Dec 5, 2020 at 17:25

Select download on the deb package. Then, wherever you saved this package, do:

sudo apt install ./discord-0.0.12.deb

Running sudo snap refresh discord works as of today. I hope this answered your question.

The response should be something like:

Johndoe@pc:~$ sudo snap refresh discord
discord 0.0.12 from Snapcrafters refreshed

It may take a bit copying over data.

  • 1
    I think this might only work if you have the snap version installed.
    – Diatrix
    Sep 15, 2020 at 15:04
  • @Diatrix, the OP posted about using Ubuntu software center, so I automatically assumed the OP was using snap. Sep 26, 2020 at 16:26
  • @puntillol59 Ubuntu 18.04 is still an LTS version that's only half-way through it's life and defaults to .debs in Ubuntu Software Centre.
    – Matthew
    Dec 5, 2020 at 9:55
  • 1
    There is sometimes a slight delay (some hours, 8 or so?) between release of the manual install .deb packages and availability of the update on the snap store. If you try this sudo snap refresh discord command it does not update, that probably means they haven't pushed the snap version of the update out yet. Patience in that case, or uninstall the snap and do a manual install of the .deb release.
    – Mike Hardy
    Dec 5, 2020 at 14:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.